Closed Bug 919818 Opened 7 years ago Closed 7 years ago

'mach build' throwing fatal assertion, failing to build on windows 8

Categories

(Firefox Build System :: Mach Core, enhancement)

x86_64
Windows 8
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 914563

People

(Reporter: ally, Unassigned)

Details

Attachments

(2 files)

Attached file machfailureoutput.txt
Barfed after upgrading to the latest mozilla build (after mach refused to build due to out of date python and directed me to installed an updated mozilla build

full log attached.

AssertionError

  File "c:\Users\A\m-c\python/mozbuild/mozbuild/mach_commands.py", line 382, in build
    monitor.finish(record_usage=status==0)
  File "c:\Users\A\m-c\python/mozbuild\mozbuild\controller\building.py", line 370, in finish
    self.resources.stop()
  File "c:\Users\A\m-c\testing/mozbase/mozsystemmonitor\mozsystemmonitor\resourcemonitor.py", line 256, in stop
    assert done
Attached file machfailedenvironment
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 914563
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.