Can't debug new packaged app with custom origin

RESOLVED FIXED in Firefox 26

Status

defect
P1
normal
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: jryans, Assigned: ochameau)

Tracking

({verifyme})

Trunk
Firefox 27
Points:
---

Firefox Tracking Flags

(firefox26 verified, firefox27 verified, b2g-v1.2 fixed)

Details

(Whiteboard: [needs-coverage])

Attachments

(2 attachments)

STR: 

1. Add the attached app to the App Manager
2. Connect to a device or simulator
3. Click "Debug"

ER:

You are supposed to get a toolbox connected to the app.

AR:

The app is installed on the device, but it does not start, and no toolbox is shown.  Eventually, the message "Unable to connect to app" appears.

However, it *is* possible to connect to the app if you disconnect, reconnect, go to Installed Apps (it doesn't update the list until you reconnect), and click "Debug" there.

Even after this reconnection dance, it is still not possible to debug from the projects page.  That button attempts to reinstall the app again.
Ok, that's because of the custom app origin field in its manifest.
  "origin": "app://test.webapi.permissions.com",

As the app is a packaged app, we create a random uuid for it and use app://$(random-uuid)/manifest.webapp manifest URL... but the app is installed with the manifest URL following its manifest overriden origin. app://test.webapi.permissions.com/manifest.webapp.

So when we try to launch the app, it fails, and it also fails when we try to get its actors.
Assignee: nobody → poirot.alex
Attachment #809869 - Flags: review+
Summary: Can't debug new packaged app → Can't debug new packaged app with custom origin
Summary: Can't debug new packaged app with custom origin → Can't debug new packaged app
Whiteboard: [needed-in-aurora-26]
Summary: Can't debug new packaged app → Can't debug new packaged app with custom origin
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/5fd6af0ff7f8
Keywords: checkin-needed
Whiteboard: [needed-in-aurora-26] → [needed-in-aurora-26][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/5fd6af0ff7f8
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [needed-in-aurora-26][fixed-in-fx-team] → [needed-in-aurora-26]
Target Milestone: --- → Firefox 27
Comment on attachment 809869 [details] [diff] [review]
Fix support of packaged apps with custom origin r=paul

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: some app
Testing completed (on m-c, etc.): Some project can't be debugged
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #809869 - Flags: approval-mozilla-aurora?
Whiteboard: [needed-in-aurora-26] → [waiting-for-aurora-approval]
Attachment #809869 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
I am not able to open the attached app using Firefox OS 1.3 Simulator. The format of the app is not recognized by the app manager. Ryan can you please provide some STR about how this attached app can be opened?
Flags: needinfo?(jryans)
You'll need to expand the .tgz file into a directory first.  On Linux or Mac, you could do that with the command "tar xzvf test-webapi-permissions.tgz".  Then, you should be able to point the App Manager at the expanded directory that you get from that.

Hopefully that helps!
Flags: needinfo?(jryans)
Verified as fixed on FF 26.05
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build id:20131114085019

Environments used:
Win 7 x64
Mac Os 10.7.5
Ubuntu 12.10 x32
Verified as fixed with Firefox 27 beta 1 (build ID: 20131209204824) on: Win 7 64-bit, Ubuntu 12.04 32-bit and Mac OS X 10.7.5
Whiteboard: [needs-coverage]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.