Include Catalan spellchecking dictionary in source tree

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: toniher, Assigned: egamonal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Catalan spellchecking dictionaries http://www.softcatala.org/wiki/Projectes/Corrector_ortogr%C3%A0fic were relicensed to GPL 2+, LGPL 2.1+ a few months ago.

As far as I know, this change should allow this dictionary to be included in the source tree. If confirmed, I would ask for committing it.

Thanks!
(Reporter)

Comment 1

5 years ago
Adding some people for comments if necessary. Sorry if spamming.
Last time I asked Gerv
https://groups.google.com/forum/#!searchin/mozilla.dev.l10n/dictionaries/mozilla.dev.l10n/beEyePLqOAs/0Vb7RKVuV2sJ

"a dictionary needs to have a licence compatible with the MPL 2 (e.g. Apache 2, BSD, MIT), or be under the LGPL."
(In reply to Toni Hermoso Pulido from comment #0)
> Catalan spellchecking dictionaries
> http://www.softcatala.org/wiki/Projectes/Corrector_ortogr%C3%A0fic were
> relicensed to GPL 2+, LGPL 2.1+ a few months ago.

That page says "GPL 2+, LGPL 2.1+". Does that mean that the entire thing is under both of those two licenses (that would be a bit odd)? Or does it mean that some parts are under one, and some parts are under the other? Is there a file or URL where the situation is explained more clearly?

Who did the relicensing and how did they go about getting permissions from the contributors?

Gerv
(Reporter)

Comment 4

5 years ago
(In reply to Gervase Markham [:gerv] from comment #3)
> (In reply to Toni Hermoso Pulido from comment #0)
> > Catalan spellchecking dictionaries
> > http://www.softcatala.org/wiki/Projectes/Corrector_ortogr%C3%A0fic were
> > relicensed to GPL 2+, LGPL 2.1+ a few months ago.
> 
> That page says "GPL 2+, LGPL 2.1+". Does that mean that the entire thing is
> under both of those two licenses (that would be a bit odd)? Or does it mean
> that some parts are under one, and some parts are under the other? Is there
> a file or URL where the situation is explained more clearly?
> 
> Who did the relicensing and how did they go about getting permissions from
> the contributors?
> 
>
Hi Gerv,

everything would be under both of the 2 licenses:

It was asked to direct contributors and public project mailing list: 
http://llistes.softcatala.org/pipermail/corrector/2013-April/000277.html
(In reply to Toni Hermoso Pulido from comment #4)
> everything would be under both of the 2 licenses:

Do you know why that is? The LGPL permits relicensing under the GPL, so it would be much simpler to just use the LGPL alone.

> It was asked to direct contributors and public project mailing list: 

I'm sorry, I'm afraid I can't parse that sentence :-(

> http://llistes.softcatala.org/pipermail/corrector/2013-April/000277.html

Google Translate does not help me here either :-(

My questions are:

* Who coordinated the relicensing?

* How did they determine who all the contributors were, back to the beginning of the project?

* How did they ask them for permission?

* Did everyone give permission? If not, what was done about that?

Gerv
(Reporter)

Comment 6

5 years ago
Hi Gerv,

I pushed for this relicensing after reading the thread Francesco linked in a previous comment above. Notice that thread was in March 2013 and the proposal of relicensing was by the end of March as well. I hope I didn't misunderstand you.

(In reply to Gervase Markham [:gerv] from comment #5)
> (In reply to Toni Hermoso Pulido from comment #4)
> > everything would be under both of the 2 licenses:
> 
> Do you know why that is? The LGPL permits relicensing under the GPL, so it
> would be much simpler to just use the LGPL alone.
> 
> > It was asked to direct contributors and public project mailing list: 
> 
> I'm sorry, I'm afraid I can't parse that sentence :-(

Putting you into context, Catalan spellchecking dictionary is maintained by this non-profit:
http://en.wikipedia.org/wiki/Softcatal%C3%A0
I'm a long-time member of that non-profit.

> 
> > http://llistes.softcatala.org/pipermail/corrector/2013-April/000277.html
> 
> Google Translate does not help me here either :-(
> 
> My questions are:
> 
> * Who coordinated the relicensing?
> 

Me. Otherwise, I don't think anyone had ever done any effort to change this... :/

> * How did they determine who all the contributors were, back to the
> beginning of the project?
> 

Apart from the people you can see here:
https://github.com/Softcatala/corrector-ortografic/graphs/contributors
there were at least 3 people that we know who also contributed before.


> * How did they ask them for permission?

We sent that message I linked to the contributors I comment above. We had communication via other channels as well (e.g., personal email and tête-à-tête) and, just in case there were unknown contributors and, because it is 'what must be done', the message was sent at the same time to the Catalan spellcheking dictionary project mailing list.

> 
> * Did everyone give permission? If not, what was done about that?
> 

All contributors that we knew supported this change and nobody has raised any issue so far.

Let me know if everything is clear. If so, what do you think it could be done from this point?

Thanks!
That all sounds great :-) Now, my only suggestion is that you go with LGPL-only, because LGPL+GPL is confusing and nobody does it - it just means more license boilerplate, and user confusion.

However, whichever you do, it's OK to ship an LGPL dictionary with Firefox.

Gerv
(Reporter)

Comment 8

5 years ago
(In reply to Gervase Markham [:gerv] from comment #7)
> That all sounds great :-) Now, my only suggestion is that you go with
> LGPL-only, because LGPL+GPL is confusing and nobody does it - it just means
> more license boilerplate, and user confusion.
> 
> However, whichever you do, it's OK to ship an LGPL dictionary with Firefox.
> 

Thanks Gerv. If already possible I'd go ahead and I'd put the stuff here:
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ca/tip/extensions/spellcheck/hunspell

This would be ca.aff, ca.dic and a README file with license information following the model I've seen for other languages.

Should I do anything else anywhere?
(Reporter)

Comment 9

5 years ago
Committed here:
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ca/rev/3cf0582e622e

Do I understand that upcoming Aurora builds will include the dictionary by default?

Comment 10

5 years ago
(In reply to Toni Hermoso Pulido from comment #9)
> Committed here:
> http://hg.mozilla.org/releases/l10n/mozilla-aurora/ca/rev/3cf0582e622e
> 
> Do I understand that upcoming Aurora builds will include the dictionary by
> default?

Yes
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

5 years ago
Verified in last Aurora build. Thanks for all the help!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.