Closed Bug 919962 Opened 8 years ago Closed 8 years ago

[MMS] Converting to text layaout when sending a MMS

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

VERIFIED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: isabelrios, Assigned: julienw)

Details

(Keywords: regression, Whiteboard: [u=commsapps-user c=messaging p=0])

Attachments

(2 files)

Attached image 2013-09-24-12-37-24.png
09/24 v1.2 build:
Gecko-85ead36
Gaia-a22ba4a

STR
1. Open messages app
2. Create a new MMS, insert a valid phone number, attach an image and write some text
3. Tap on Send

EXPECTED
The MMS is correctly sent all the info presented to user is right

ACUTAL
After tapping on send, there is a layaout under the header: converting to text message. Althoug the message sent is an MMS. 
Please see screenshot attached
qawanted: does this happen on 1.1 ?
Keywords: qawanted
No, cannot reproduce the same on 1.1.
Keywords: qawanted
Whiteboard: [u=commsapps-user c=messaging p=0]
looks like a regression from bug 902497 too
Assignee: nobody → felash
Attached patch patch v1Splinter Review
see also PR https://github.com/mozilla-b2g/gaia/pull/12514

We now display the banner in an asynchronous way therefore the previous way to
hide the banner synchronously didn't work.

This patch changes the logic then: instead of hiding the banner after displaying
it, it now prevents the banner from being displayed at all.
---
 apps/sms/js/thread_ui.js             |   11 +++++++----
 apps/sms/test/unit/thread_ui_test.js |   20 ++++++++++++++++++++
 2 files changed, 27 insertions(+), 4 deletions(-)
Attachment #811328 - Flags: review?(gnarf37)
Comment on attachment 811328 [details] [diff] [review]
patch v1

Review of attachment 811328 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me - setting that data type feels a little awkward, but the unit test will guard against a future regression here hopefully - R+
Attachment #811328 - Flags: review?(gnarf37) → review+
master: 0be3d8942a89e35fbd3a07106de4b4f1b18f75ed
yeah I tried to make that unit test independant of that data type.

Ideally we should probably keep a "previousType" var instead of abusing the dataset.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
triage: regression. koi+
blocking-b2g: koi? → koi+
Verified 10/01 v1.2 build:
Gecko-b318b86
Gaia-d9f9000
Status: RESOLVED → VERIFIED
Uplifted 0be3d8942a89e35fbd3a07106de4b4f1b18f75ed to:
v1.2: 29ad4160703d72feb368cedf09314acc46429858
You need to log in before you can comment on or make changes to this bug.