If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[User Story] Delete multiple contacts

RESOLVED DUPLICATE of bug 956219

Status

Firefox OS
Gaia::Contacts
P1
blocker
RESOLVED DUPLICATE of bug 956219
4 years ago
4 years ago

People

(Reporter: WDM, Assigned: arcturus)

Tracking

({feature})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ucid:Comms35, 1.4:P2, ft:comms])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
User story:

As a user I want to be able to select multiple contacts and delete.


Acceptance Criteria:

AC 1: I am offered in any situation where I can delete a contact a possibility to select multiple contacts
(Reporter)

Updated

4 years ago
Flags: in-moztrap?(jhammink)
Summary: [User Story] Delete multiple contacts → [User Story] Delete multiple contacts (FFOS 1.3)
Hey Ayman, before starting to work on it would like your input.

My idea here is reuse the select list that we have for exporting, but instead of that for delete.

I'll need some feedback on how the interaction should be. Will prepare a poc so you can take a look.

Thanks!
Assignee: nobody → francisco.jordano
Flags: needinfo?(aymanmaat)
Hi folks,

prelimiar poc of the multiple delete:

https://github.com/arcturus/gaia/tree/bug-920009

(yes perhaps it has a bug, but at least it's trying to show a possible workflow, always pending from Ayman words)

Thanks!

Updated

4 years ago
Flags: needinfo?(aymanmaat)

Comment 3

4 years ago
removed the ni? to me by mistake whilst doing some bug admin putting it back.
Flags: needinfo?(aymanmaat)
Created attachment 814899 [details]
poc running on nightly
Attachment #814899 - Flags: feedback?(aymanmaat)

Comment 5

4 years ago
Comment on attachment 814899 [details]
poc running on nightly

Hey Francisco

Ok, overall in terms of IxD your totally in the ball park with this. There are just three points that I think  need to be tweeked: 

1) I know you have used the export contacts as your working template which is correct, however we need to align the visual treatment of this screen to the Delete interface of the message app as they are functionally related (delete should have the same visual treatment and therefore speak the same visual language everywhere) I will ni? Victoria to provide you with the assets.

2) @ 00:21 : When one or more contacts is selected the header should change its label from 'Contacts' to ''n' selected'. This both keeps the user orientated as to the number of contacts selected when the selected contacts are not visible on the screen, therefore lowering their cognitive loading, and also aligns the 'Selection to Delete' functionality to that in the Messages App and Call Log.

3) @ 00:23 : The last part of the alphabet in the column on the right hand side of the screen is covered by the screens Footer and is therefore not accessible. Victoria should be able to fix this when she produces the Visual Design for you.

…Apart from that it all looks good to me

Comment 6

4 years ago
Reference Comment 5
Flags: needinfo?(aymanmaat) → needinfo?(vpg)

Updated

4 years ago
QA Contact: isabelrios
Hi All,

There's no need for Visual Design here as this the deleting action is widely used all across the system. Please use the correct Building Block and you'll have no problem: http://buildingfirefoxos.com/building-blocks/edit-mode.html

Thanks.
Flags: needinfo?(vpg)
QA Contact: isabelrios
Created attachment 815287 [details]
Visual QA for delete multiple contacts, selection screen
Hey,

There's a bug for solving the index length issue when in edit mode: https://bugzilla.mozilla.org/show_bug.cgi?id=923143

I have attached a detailed exam of the layout implementation based on the video shared. A few things are pointed out. If you have any further question or doubt, please needinfo me.

Updated

4 years ago
Target Milestone: --- → 1.3 Sprint 3 - 10/25
(Reporter)

Updated

4 years ago
No longer blocks: 917190
(Reporter)

Updated

4 years ago
Blocks: 920625
This bug is actively worked but isn't a release blocker, it will land once fixed.

Updated

4 years ago
QA Contact: isabelrios

Updated

4 years ago
Target Milestone: 1.3 Sprint 3 - 10/25 → ---
blocking-b2g: 1.3? → 1.4?
Summary: [User Story] Delete multiple contacts (FFOS 1.3) → [User Story] Delete multiple contacts
Whiteboard: [ucid:Comms35, 1.4:P2, ft:comms]
Blocks: 945644
No longer blocks: 920625
Wilfred, this is not in your excel Google doc comms sheet but it's in your email as targeted. Can you confirm this user story for 1.4 targeted? Thanks
Flags: needinfo?(wmathanaraj)
(Reporter)

Comment 12

4 years ago
its in google doc - just not following the other sections - its further down the list. Confimred its  target.
Flags: needinfo?(wmathanaraj)

Comment 13

4 years ago
Can you please provide the patch for the implementation of multiple delete of contacts, as shown in the video ?
Flags: needinfo?(francisco.jordano)
@ashab2g that was a PoC, with some fails, will need to invest some time on it and right now have other committed features.

If I find the time in 1.4 will do it.

Thanks,
F.
Flags: needinfo?(francisco.jordano)

Comment 15

4 years ago
@francisco, Can you please provide the work in progress patch ? so that we can take it forward.

Thanks,
Ashay
Flags: needinfo?(francisco.jordano)
Sure the work is in a branch here:

https://github.com/arcturus/gaia/tree/bug-920009

It's quite outdated, but easy to follow.

Regards,
F.
Flags: needinfo?(francisco.jordano)

Comment 17

4 years ago
Please assign this task to me as I am unable to assign it to myself.

Thanks
Ashay
Flags: needinfo?(francisco.jordano)

Comment 18

4 years ago
Created attachment 8353767 [details] [diff] [review]
WorkInProgress_MultiContactDelete.patch

Hi Francisco,
   Attaching work in progress patch for Multiple Contact Delete. Please review and let me know your feedback.

Regards
Ashay

Comment 19

4 years ago
Hi Wchang,
   As Francisco is PTO till 11th Jan, Can you please assign some one for patch review and let us know the feedback.

Regards
Ashay
Flags: needinfo?(wchang)
Jose, maybe you can help?

(In reply to ashayb2g from comment #19)
> Hi Wchang,
>    As Francisco is PTO till 11th Jan, Can you please assign some one for
> patch review and let us know the feedback.
> 
> Regards
> Ashay
Flags: needinfo?(wchang) → needinfo?(jmcf)

Updated

4 years ago
Depends on: 956219

Comment 21

4 years ago
ashayb2g@gmail.com please could you attach a Github PR in order to properly review your patch?. On the other hand I'm concerned on the changes you have done to navigation.js, are they really necessary? There is code commented as well on your patch ...
Flags: needinfo?(jmcf)
Flags: needinfo?(francisco.jordano)

Comment 22

4 years ago
@Jose, Please refer https://bugzilla.mozilla.org/show_bug.cgi?id=956219 as an implementation of Multiple Contact Delete. PR is attached in this bug request.

Regarding navigation.js, on Multiple Delete screen it was not getting the proper zIndex because of two navigation stack.
Duplicate of this bug: 961633

Updated

4 years ago
Blocks: 891754
This is a target for 1.4
blocking-b2g: 1.4? → ---

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 956219
Resolution: --- → DUPLICATE
Duplicate of bug: 956219

Updated

4 years ago
Flags: in-moztrap?(jhammink)
You need to log in before you can comment on or make changes to this bug.