Consolidate "ensure parent directory" logic

NEW
Unassigned

Status

()

Core
Build Config
4 years ago
4 years ago

People

(Reporter: gps, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
mozbuild.util has an ensureParentDir function. It should be renamed to ensure_parent_dir for style reasons and it should gain the ability to ensure write access is present on the directory (like what's done in mozpack.copier). Code in mozpack.copier should also be changed to use it.

We may also want a variation or mode where only 1 directory (not the entire intermediate tree) is created.
You need to log in before you can comment on or make changes to this bug.