Closed Bug 920337 Opened 7 years ago Closed 7 years ago

Race when loading projects

Categories

(DevTools Graveyard :: WebIDE, defect, P1)

defect

Tracking

(firefox26 fixed, firefox27 fixed)

RESOLVED FIXED
Firefox 27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed

People

(Reporter: jryans, Assigned: jryans)

Details

(Whiteboard: [qa-])

Attachments

(1 file)

It's possible for AppProjects to finish loading the projects before UI.init in projects.js runs, which prevents the projects from ever being validated.
Instead of watching an event from the store that may never arrive, use a promise to be sure we validate the projects.
Attachment #809603 - Flags: review?(paul)
Attachment #809603 - Flags: review?(paul) → review+
Whiteboard: [needed-in-aurora-26]
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/a0f892c84c7e
Keywords: checkin-needed
Whiteboard: [needed-in-aurora-26] → [needed-in-aurora-26][fixed-in-fx-team]
Comment on attachment 809603 [details] [diff] [review]
Use promise to ensure we don't miss project load

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: some projects might not load
Testing completed (on m-c, etc.): fx-team
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #809603 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/a0f892c84c7e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [needed-in-aurora-26][fixed-in-fx-team] → [needed-in-aurora-26]
Target Milestone: --- → Firefox 27
Attachment #809603 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [needed-in-aurora-26] → [land-in-aurora-26]
Whiteboard: [qa-]
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.