Update code to use controller.select() in testPreferences/testPreferredLanguage.js

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: andrei, Assigned: andrei)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(firefox24 fixed, firefox25 fixed, firefox26 fixed, firefox27 fixed, firefox-esr17 fixed, firefox-esr24 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
We need to update the following code:

> // Select the language in the dropdown
> // Bug 852116
> // TODO: replace this code with controller.select() once 852116 lands
> aController.click(langDropDown);
> assert.waitFor(function () {
>     return langDropDown.getNode().open;
> }, "Language Drop Down has been opened");
> aController.click(filteredLanguageList.elements[randomPosition]);
> aController.click(langDropDown);

With:
> controller.select()

We get a failure in 1.5.23 right now:
http://mozmill-staging.blargon7.com/#/functional/report/837c1e0f361ac93453ee6972195e578b

Probably due to bug 912941 getting landed.
Lets get this fixed on all branches, so that we can upgrade to 1.5.23 on production later today.
Blocks: 852116
No longer depends on: 852116
Keywords: regression
Priority: -- → P1
(Assignee)

Updated

5 years ago
status-firefox24: --- → affected
status-firefox25: --- → affected
status-firefox26: --- → affected
status-firefox27: --- → affected
status-firefox-esr17: --- → affected
status-firefox-esr24: --- → affected
(Assignee)

Comment 2

5 years ago
Created attachment 809813 [details] [diff] [review]
1.patch

I've replaced the block of code with controller.select()

Appears to be working very nice:

1.5
===
OSX: http://mozmill-crowd.blargon7.com/#/functional/report/837c1e0f361ac93453ee69721961af4b
Windows: http://mozmill-crowd.blargon7.com/#/functional/report/837c1e0f361ac93453ee6972196358a8

2.0
===
OSX: http://mozmill-crowd.blargon7.com/#/functional/report/837c1e0f361ac93453ee697219668f39

I'm currently refreshing my Linux vm, it crashes randomly so I couldn't get a full testrun, the test run independently passes.
Assignee: nobody → andrei.eftimie
Status: NEW → ASSIGNED
Attachment #809813 - Flags: review?(andreea.matei)
Comment on attachment 809813 [details] [diff] [review]
1.patch

Review of attachment 809813 [details] [diff] [review]:
-----------------------------------------------------------------

Landed on:
http://hg.mozilla.org/qa/mozmill-tests/rev/873efca9cfb0 (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/54e78e9b5177 (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/4fe794cb9584 (beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/0fcc18a85f9c (release)
http://hg.mozilla.org/qa/mozmill-tests/rev/84909a10c30b (esr24)
http://hg.mozilla.org/qa/mozmill-tests/rev/c73a54014340 (esr17)

Note that esr17 will fail for 1.5.22 due to the select() method, on 1.5.23 it's all good.
Attachment #809813 - Flags: review?(andreea.matei) → review+
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox24: affected → fixed
status-firefox25: affected → fixed
status-firefox26: affected → fixed
status-firefox27: affected → fixed
status-firefox-esr17: affected → fixed
status-firefox-esr24: affected → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.