Intermittent PROCESS-CRASH | tcheck2 | application crashed [@ mozalloc_abort(char const*)]

RESOLVED DUPLICATE of bug 910106

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 910106
5 years ago
5 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({crash})

Trunk
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

5 years ago
Android 2.2 Tegra b2g-inbound talos remote-trobocheck2 on 2013-09-25 03:28:44 PDT for push d2303df55b22

slave: tegra-070

https://tbpl.mozilla.org/php/getParsedLog.php?id=28338235&tree=B2g-Inbound

PROCESS-CRASH | tcheck2 | application crashed [@ mozalloc_abort(char const*)]
Crash dump filename: /tmp/tmps31I9Z/5601e890-611c-f2f4-613e1ce9-3c8d7997.dmp
Operating system: Android
                  0.0.0 Linux 2.6.32.9-00002-gd8084dc-dirty #1 SMP PREEMPT Wed Feb 2 11:32:06 PST 2011 armv7l nvidia/harmony/harmony/harmony:2.2/FRF91/20110202.102810:eng/test-keys
CPU: arm
     2 CPUs

Crash reason:  SIGSEGV
Crash address: 0x0

Thread 0 (crashed)
 0  libmozalloc.so!mozalloc_abort(char const*) [mozalloc_abort.cpp : 30 + 0x4]
     r4 = 0x0000aa50    r5 = 0x00000000    r6 = 0x483f33f0    r7 = 0x430cbf30
     r8 = 0xbea7d7b0    r9 = 0x430cbf28   r10 = 0x430cbf14    fp = 0x00000000
     sp = 0xbea7d728    lr = 0x4498b0bb    pc = 0x4498b0be
    Found by: given as instruction pointer in context
 1  libxul.so!Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash [AndroidJNI.cpp:d2303df55b22 : 103 + 0x3]
     r4 = 0x0000aa50    r5 = 0x00000000    r6 = 0x483f33f0    r7 = 0x430cbf30
     r8 = 0xbea7d7b0    r9 = 0x430cbf28   r10 = 0x430cbf14    fp = 0x00000000
     sp = 0xbea7d730    pc = 0x55939327
    Found by: call frame info
 2  libmozglue.so!Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash [jni-stubs.inc:d2303df55b22 : 108 + 0x1]
     r4 = 0x0000aa50    r5 = 0x00000000    r6 = 0x483f33f0    r7 = 0x430cbf30
     r8 = 0xbea7d7b0    r9 = 0x430cbf28   r10 = 0x430cbf14    fp = 0x00000000
     sp = 0xbea7d7a8    pc = 0x80c1b4d7
    Found by: call frame info
 3  libdvm.so + 0x16e36
     r4 = 0xbea7d7d0    r5 = 0x00000000    r6 = 0x483f33f0    r7 = 0x430cbf30
     r8 = 0xbea7d7b0    r9 = 0x430cbf28   r10 = 0x430cbf14    fp = 0x00000000
     sp = 0xbea7d7b0    pc = 0x80816e38
    Found by: call frame info
 4  dalvik-LinearAlloc (deleted) + 0x22bb42
     sp = 0xbea7d7b8    pc = 0x432f7b44
    Found by: stack scanning
 5  2 (deleted) + 0x6d3ee
     sp = 0xbea7d7bc    pc = 0x483f33f0
    Found by: stack scanning
 6  libdvm.so + 0x16ffe
     sp = 0xbea7d7c4    pc = 0x80817000
    Found by: stack scanning
Comment hidden (Treeherder Robot)

Updated

5 years ago
Depends on: 910320

Comment 2

5 years ago
Comment 0; from logcat:
{
09-25 03:36:59.204 E/GeckoAppShell( 2210): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
09-25 03:36:59.204 E/GeckoAppShell( 2210): java.lang.IllegalStateException: Fragment already added: PinSiteDialog{48479c50 #4 pin_site}
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at android.support.v4.app.FragmentManagerImpl.addFragment(FragmentManager.java:1159)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at android.support.v4.app.BackStackRecord.run(BackStackRecord.java:616)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at android.support.v4.app.FragmentManagerImpl.execPendingActions(FragmentManager.java:1444)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at android.support.v4.app.FragmentManagerImpl$1.run(FragmentManager.java:429)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at android.os.Handler.handleCallback(Handler.java:587)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at android.os.Handler.dispatchMessage(Handler.java:92)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at android.os.Looper.loop(Looper.java:123)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at java.lang.reflect.Method.invokeNative(Native Method)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at java.lang.reflect.Method.invoke(Method.java:521)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
09-25 03:36:59.204 E/GeckoAppShell( 2210): 	at dalvik.system.NativeStart.main(Native Method)
}

Comment 1; from logcat:
{
09-25 05:59:03.546 E/GeckoAppShell( 2469): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
09-25 05:59:03.546 E/GeckoAppShell( 2469): java.lang.IllegalStateException: Fragment already added: PinSiteDialog{484e3160 #4 pin_site}
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at android.support.v4.app.FragmentManagerImpl.addFragment(FragmentManager.java:1159)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at android.support.v4.app.BackStackRecord.run(BackStackRecord.java:616)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at android.support.v4.app.FragmentManagerImpl.execPendingActions(FragmentManager.java:1444)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at android.support.v4.app.FragmentManagerImpl$1.run(FragmentManager.java:429)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at android.os.Handler.handleCallback(Handler.java:587)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at android.os.Handler.dispatchMessage(Handler.java:92)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at android.os.Looper.loop(Looper.java:123)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at java.lang.reflect.Method.invokeNative(Native Method)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at java.lang.reflect.Method.invoke(Method.java:521)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
09-25 05:59:03.546 E/GeckoAppShell( 2469): 	at dalvik.system.NativeStart.main(Native Method)
}

Comment 3

5 years ago
The test disabling in bug 910106 morphed the failures there to this. Will back out the test disabling.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 910106
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.