New OS X style vertical scrollbar is hidden by articles in Digg Reader

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
7 days ago

People

(Reporter: sunjw8888, Unassigned)

Tracking

Firefox 24
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needaccount] [country-us] [css] [contactready], URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 809898 [details]
屏幕快照 2013-09-25 下午10.31.31.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

1. Open Digg Reader
2. Scroll content in news list on the right.


Actual results:

The new style OS X scrollbar doesn't show on the whole right side, just a little on the top


Expected results:

The new style OS X scrollbar show on the whole right side
(Reporter)

Comment 1

6 years ago
Created attachment 809899 [details]
屏幕快照 2013-09-25 下午10.31.47.png
(Reporter)

Updated

6 years ago
Component: Untriaged → General

Updated

6 years ago
Blocks: 636564
Component: General → Widget: Cocoa
Product: Firefox → Core
This appears to be caused by the <article> element of class " expanded api feeditem-read feed-item-focused" having a higher z-index (z-index: 2) than the scrollable element. This is similar to bug 891136 and the solution was for the website to:
1. Give the scrollable element a higher z-index than the element with the articles.
2. Make the scrollable element 'pointer-events:none'.

It is possible that Digg Reader made the z-index of the scrollable element lower than the z-index of the element with the articles to avoid the scrollable element catching pointer events meant for the articles. Step 2 works around this problem.

CC-ing roc in case I missed something. Otherwise, this looks like a tech evangelism bug to me.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: Widget: Cocoa → English US
Depends on: 891136
Ever confirmed: true
Product: Core → Tech Evangelism
Version: 24 Branch → Firefox 24
Summary: New OS X style vertical scrollbar doesn't fit in the whole scrollable area → New OS X style vertical scrollbar is hidden by articles in Digg Reader
(Reporter)

Comment 3

6 years ago
In Firefox 25 beta 2, the bug 891136 is fixed, but vertical scrollbar in Digg reader still not display correctly.
(In reply to Sun from comment #3)
> In Firefox 25 beta 2, the bug 891136 is fixed, but vertical scrollbar in
> Digg reader still not display correctly.

You're correct. Bug 891136 tracked the work on our side. After that patch landed, Google Docs still had to make changes on their end to make use of the fix. Digg Reader will need to do the same. Steps for Digg Reader are outlined in comment 2.
Assignee: english-us → nobody
Component: English US → Desktop
Whiteboard: [needaccount] [country-us] [css] [contactready]
Does this still happen? We changed to code recently to fix things like this.
This is fixed, just signed up and tested.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Component: Desktop → Desktop
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.