confusing notification raised by Firefox Nightly

RESOLVED FIXED in Firefox 27

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: bhearsum, Assigned: jrconlin)

Tracking

unspecified
Firefox 27
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

My Nightly raised a notification a few minutes ago that simply had "3" on one line and "4" below it. When I tap on it, Nightly opens a new tab and goes to https://campaigns.services.mozilla.com/redirect/1/1voQlZpKX, which 404s.
12:00 < elan> mfinkle: that's obviously product announcement
12:01 <@mfinkle> jessemontano, ^
12:01 < elan> announcements*
12:01 <@mfinkle> elan, agreed
12:01 < jessemontano> just saw your email
12:01 < elan> jrconlin: ^
12:01 -!- iamjayakumars [iamjayakum@71FD09FD.7297CEDB.9D59D0D8.IP] has joined #mobile
12:01 < jessemontano> i have not sent anything out
12:01 -!- sole [sole@88F51059.F3BBB17D.144F44FA.IP] has quit [Input/output error]
12:01 < jessemontano> i was about to login in the dashbaord
12:01 <@mfinkle> ok
12:01 < elan> bhearsum: can you need info JR Conlin?
12:01 -!- juanb [jbecerra@moz-BBE3ABD.mv.mozilla.com] has joined #mobile
12:01 -!- RodrigoWaters [Thunderbir@1F725018.F5F1BD8.A0EDED9D.IP] has quit [Quit: RodrigoWaters]
12:02 -!- Irina [Irina@13F2CEC5.7672369.D8E68FF6.IP] has joined #mobile
12:02 < jessemontano> someone else usually runs tests as well.. not sure who though
12:02 < bhearsum> sure
Flags: needinfo?(jrconlin)
Component: General → Server: Product Announcements Redirector
Product: Firefox for Android → Mozilla Services
It appears that these were created by a QA engineer. I've removed the records from production and will have a brief education period with him when he comes online.

Sadly, devices that have already picked up the announcements will display them and return a 404 on link. There's not much we can do to solve for that.
Status: NEW → RESOLVED
Closed: 6 years ago
Component: Server: Product Announcements Redirector → General
Flags: needinfo?(jrconlin)
Product: Mozilla Services → Firefox for Android
Resolution: --- → FIXED
Thanks for the investigation, JR.

* Are we confident that this was nightly only? 
* Do we need safeguards (beyond education) to prevent this type of thing in the future?
Duplicate of this bug: 920604
Duplicate of this bug: 920620
Target Milestone: --- → Firefox 27
(In reply to Johnathan Nightingale [:johnath] from comment #3)
> Thanks for the investigation, JR.
> 
> * Are we confident that this was nightly only? 
> * Do we need safeguards (beyond education) to prevent this type of thing in
> the future?

Campaign Manager was a "hack" project requested on a short timeline. Because of that, a LOT of corners were cut. As my other high priority project is settling down to "panic levels", I'm able to go back to Campaign Manager and weld some of those corners back on (including filling out a proper Project Template page for the thing: https://wiki.mozilla.org/User:Jrconlin/NewProjectTemplate 

That said, I'm taking assignment of this bug and will close it once a proper account management element has been added to Campaign Manager.
Assignee: nobody → jrconlin
You need to log in before you can comment on or make changes to this bug.