[B2G] B2G launched by Marionette failed to fire touch events due to the profile issue

RESOLVED DUPLICATE of bug 891882

Status

defect
RESOLVED DUPLICATE of bug 891882
6 years ago
2 years ago

People

(Reporter: gweng, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR:

 1. In the Gaia directory, use '/bin/gaia-marionette <path to the test>' to launch B2G automatically and run any test of them.

*2. In the terminal, Ctrl-C to interrupt the test and leave the B2G running.

 3. Use Home or FN-right keys to turn the screen off

 4. Try to drag the LockScreen handle by mouse manually

Expected:

The handle will move as on device.

Actual Results:

The handle won't move.

---

NOTE: In step 2 I make the test interrupted. This can be replaced by press the handle and drag it via MarionetteJS in the test case, though it's going to fail, too.

---

I've made a trick on the LockScreen itself to listen the click event and paint the background red. This trick *worked* well. Nevertheless the same trick only replace the listener with 'touchstart' would *NOT work*, so we seems encountered the touch events here.

Beside that, this problem *won't appear* on the B2G launched manually, which is in Gaia repo and should be the same with the one launched by Marionette. The only difference between these two B2G is the former use 'profile-debug' generated by myself, rather than the 'profile-test'.

Another related test is that manually launch the B2G with 'profile-test' & 'profile-debug'. In this way the 'profile-debug' one would work well but the 'profile-test' won't.
Component: Marionette → JSMarionette
Blocks: 916035
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 891882
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.