jobqueue.pl and/or File::Slurp does not work on Perl 5.10.0

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: krzysztof.strug, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 810403 [details]
Parameters Email 2013-09-26 08-23-18.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Upgrade Bugzilla from 4.2.6 to 4.4 following procedure from bugzilla web. Email configuration in attached screenshot. 




Actual results:

After upgrade no email notifications from bugzilla using jobqueue.pl. Second attachment with output from "jobqueue.pl once -f -d".

When I switch "use_mailer_queue" to off everything works perfectly.
(Reporter)

Comment 1

5 years ago
Created attachment 810405 [details]
jobqueue.pl-output.PNG

Comment 2

4 years ago
I'm encountering this too while updating the OS on my Bugzilla servers (Bugzilla 4.4.1 not touched).  Servers running older OS'es and older Perl work fine, but if I upgrade the server to something more recent, checksetup shows this:

Checking for          TheSchwartz (v1.07)     ok: found v1.10 
v-string in use/require non-portable at lib/File/Slurp.pm line 3, <DATA> line 751.
Checking for       Daemon-Generic (any)       ok: found v0.84 

Email in the ts_jobs table look like this:
From
!ARRAY(0x2f71e10)@bugs.eclipse.org
To
ARRAY(0x2dc9b90)
Subject
ARRAY(0x2fe9250)
Date
ARRAY(0x2efc3f0)
X-Bugzilla-Reason
ARRAY(0x2e03140)
X-Bugzilla-Type
ARRAY(0x2e03130)
X-Bugzilla-Watch-Reason
ARRAY(0x2efc850)
X-Bugzilla-Classification
ARRAY(0x2fe87d0)
X-Bugzilla-Product
ARRAY(0x2c567d0)
X-Bugzilla-Component
ARRAY(0x2e16a30)
X-Bugzilla-Version
ARRAY(0x2efc6a0)
X-Bugzilla-Keywords
ARRAY(0x2efc6c0)
X-Bugzilla-Severity
ARRAY(0x2e032b0)
X-Bugzilla-Who
ARRAY(0x2fff520)
X-Bugzilla-Status
ARRAY(0x2fff460)
X-Bugzilla-Priority
ARRAY(0x2e02f50)
X-Bugzilla-Assigned-To
ARRAY(0x2c646d0)
-Bugzilla-Target-Milestone
ARRAY(0x2c63970)
X-Bugzilla-Flags
ARRAY(0x2e02f10)
X-Bugzilla-Changed-Fields
ARRAY(0x2c63a90)

Message-ID
ARRAY(0x2fe8ee0)

Mail obviously cannot be sent:
Jun 17 11:27:21 bugs-vm2 jobqueue.pl[16684]: Working on Bugzilla::Job::Mailer ...
Jun 17 11:27:21 bugs-vm2 jobqueue.pl[16684]: job failed.  considering retry.  is max_retries of 725 >= failures of 4?
Jun 17 11:27:21 bugs-vm2 jobqueue.pl[16684]: job failed: There was an error sending mail from
Jun 17 11:27:21 bugs-vm2 jobqueue.pl[16684]: 'ARRAY(0x2c645a0)@bugs.eclipse.org' to 'ARRAY(0x2c645f0)': Can't send
Jun 17 11:27:21 bugs-vm2 jobqueue.pl[16684]: data


I rm -rf'ed the lib/ directory and rebuilt all the needed Perl modules.. no dice.
denis, can you please attach the full output from checksetup?  i'm mostly interested in the versions of each installed module and perl itself.
Flags: needinfo?(webmaster)

Comment 4

4 years ago
Sure.

# ./checksetup.pl --check-modules
* This is Bugzilla 4.4.1 on perl 5.10.0
* Running on Linux 3.0.101-0.31-xen #1 SMP Wed Jun 4 08:59:53 UTC 2014 (87c5279)

Checking perl modules...
Checking for               CGI.pm (v3.51)     ok: found v4.02 
Checking for           Digest-SHA (any)       ok: found v5.45 
Checking for             TimeDate (v2.23)     ok: found v2.24 
Checking for             DateTime (v0.28)     ok: found v1.10 
Checking for    DateTime-TimeZone (v0.71)     ok: found v1.70 
Checking for                  DBI (v1.54)     ok: found v1.607 
Checking for     Template-Toolkit (v2.22)     ok: found v2.25 
Checking for           Email-Send (v2.04)     ok: found v2.199 
Checking for           Email-MIME (v1.904)    ok: found v1.926 
Checking for                  URI (v1.37)     ok: found v1.60 
Checking for       List-MoreUtils (v0.32)     ok: found v0.33 
Checking for    Math-Random-ISAAC (v1.0.1)    ok: found v1.004 

Checking available perl DBD modules...
Checking for               DBD-Pg (v2.7.0)    not found 
Checking for            DBD-mysql (v4.001)    ok: found v4.008 
Checking for           DBD-SQLite (v1.29)     found v1.14 
Checking for           DBD-Oracle (v1.19)     not found 

The following Perl modules are optional:
Checking for                   GD (v1.20)     ok: found v2.53 
Checking for                Chart (v2.1)      ok: found v2.4.6 
Checking for          Template-GD (any)       ok: found v1.56 
Checking for           GDTextUtil (any)       ok: found v0.86 
Checking for              GDGraph (any)       ok: found v1.48 
Checking for           MIME-tools (v5.406)    ok: found v5.505 
Checking for          libwww-perl (any)       ok: found v5.816 
Checking for             XML-Twig (any)       not found 
Checking for          PatchReader (v0.9.6)    ok: found v0.9.6 
Checking for            perl-ldap (any)       ok: found v0.63 
Checking for          Authen-SASL (any)       ok: found v2.16 
Checking for         Net-SMTP-SSL (v1.01)     not found 
Checking for           RadiusPerl (any)       not found 
Checking for            SOAP-Lite (v0.712)    not found 
Checking for          XMLRPC-Lite (v0.712)    not found 
Checking for             JSON-RPC (any)       ok: found v1.04 
Checking for              JSON-XS (v2.0)      ok: found v3.01 
Checking for           Test-Taint (any)       ok: found v1.06 
Checking for          HTML-Parser (v3.40)     ok: found v3.56 
Checking for        HTML-Scrubber (any)       ok: found v0.11 
Checking for               Encode (v2.21)     ok: found v2.23 
Checking for        Encode-Detect (any)       ok: found v1.01 
Checking for          Email-Reply (any)       ok: found v1.203 
Checking for HTML-FormatText-WithLinks (v0.13)     ok: found v0.14 
Checking for          TheSchwartz (v1.07)     ok: found v1.10 
v-string in use/require non-portable at lib/File/Slurp.pm line 3, <DATA> line 751.
Checking for       Daemon-Generic (any)       ok: found v0.84 
Checking for             mod_perl (v1.999022) ok: found v2.000004 
Checking for     Apache-SizeLimit (v0.96)     not found 
Checking for        File-MimeInfo (any)       not found 
Checking for           IO-stringy (any)       ok: found v2.110 
***********************************************************************
Flags: needinfo?(webmaster)
(In reply to Denis Roy from comment #4)
> * This is Bugzilla 4.4.1 on perl 5.10.0

Maybe it's the Perl version.. There's a reason we require 5.10.1 in our next major version and not 5.10.0, see bug 655477 for more detail.

> v-string in use/require non-portable at lib/File/Slurp.pm line 3, <DATA> line 751.

This seems to be https://rt.cpan.org/Public/Bug/Display.html?id=71207 and based on various reports around this does seem to also affect especially Perl 5.10.0.

Comment 6

4 years ago
We'll keep an eye out for the version of Perl.  For now we're using what is supplied by the distro, and we'll keep avoiding jobqueue.pl until we're confident we don't have an issue.  My first thought was that it was a Slurp issue.

Thanks for the pointers.
Comment hidden (off-topic)

Comment 8

3 years ago
(In reply to dylahu from comment #7)
> Could you help me fix it?

This is not the right place to ask for help. Please visit http://www.bugzilla.org/support.
Summary: jobqueue.pl is not working properly → jobqueue.pl and/or File::Slurp does not work on Perl 5.10.0

Comment 9

3 years ago
Bugzilla 5.0 requires Perl 5.10.1 or newer on purpose, because 5.10.0 is known to be buggy. If you are running Perl 5.10.0, your only realistic option is to upgrade to 5.10.1. You can compile it yourself; it's not hard to do.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.