Handle empty placeholders for downloaded files appropriately

RESOLVED DUPLICATE of bug 1139913

Status

()

defect
RESOLVED DUPLICATE of bug 1139913
6 years ago
2 years ago

People

(Reporter: Paolo, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

In the Downloads API, we currently ensure that an empty placeholder file is
present in the real target location while a download is in progress.

When the download fails or is stopped, the placeholder is removed. We might
want to keep the placeholder in case we are also preserving partially
downloaded data, though having a zero-sized file with the final extension
kept in place for a long time might not be ideal.
Blocks: 1139913
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1139913
You need to log in before you can comment on or make changes to this bug.