Clicking on item in download panel not working on Windows 8.1 RTM

RESOLVED INVALID

Status

()

Firefox
Downloads Panel
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: mscrivo, Unassigned)

Tracking

26 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130925004004

Steps to reproduce:

1. Download any type of file.
2. Click on it from the download panel.


Actual results:

Nothing.  The file does not execute.   It will execute if you double click on it from the full downloads list.

This is working fine with Aurora 26 on Windows 7, and it's also working fine in Firefox 24 on Windows 8.1 RTM, but not in Aurora 26 on Windows 8.1 RTM.


Expected results:

The item should be shell executed with whatever program is associated with the file type.
(Reporter)

Updated

5 years ago
OS: Windows NT → Windows 8.1
(Reporter)

Comment 1

5 years ago
Same problem exists in firefox safe mode, so I don't think it's an add-on interfering.
Component: Untriaged → Downloads Panel
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130930004008

Works fine for me on the latest Aurora - I downloaded an exe file, clicking once on the download in the downloads panel executes the application.

Reporter, are you by any chance running Firefox in Metro mode?
Flags: needinfo?(mscrivo)
(Reporter)

Comment 3

5 years ago
I am not running it in metro mode.  I tried the metro version briefly, just to see what it was like, but I use it predominantly in desktop mode.  Is there an actual option to turn off metro mode completely?  even if launched from the start screen?
Flags: needinfo?(mscrivo)
I'm afraid not - the metro mode is on as long as Firefox is the default browser.
Reporter, could you also check if the issue is reproducible for you if you start Firefox with a new profile? (other possible cause could be due to changes made to Firefox preference settings)

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
(Reporter)

Comment 6

5 years ago
Whether Aurora is default or not makes no difference.  I tried with a new profile and it worked, so I guess it's something in my profile that's messed up?
(Reporter)

Comment 8

5 years ago
Resetting my profile worked. You may close this. Thanks
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.