Closed Bug 921191 Opened 6 years ago Closed 6 years ago

allow inspection/editing of SVG elements' CSS properties

Categories

(DevTools :: Inspector, defect)

27 Branch
x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 27

People

(Reporter: spasovski, Assigned: paul)

References

Details

Attachments

(1 file, 2 obsolete files)

No description provided.
Summary: allow inspection of SVG elements → allow inspection/editing of SVG elements' CSS properties
Sorry hit 'enter' too early on this bug.

I realize SVG elements have some nonstandard CSS properties but it would be awesome if we were able to inspect and edit them the way you can with regular DOM nodes.

Please let me know if you need a better description.
As far as I can tell, the inspector doesn't currently display any CSS rules for SVG nodes, even the non-specific ones. It makes debugging this stuff a lot harder than debugging normal HTML. :-(
Attached patch Patch V1 (obsolete) — Splinter Review
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #814786 - Flags: review?(mratcliffe)
Regression happened in 26. We'll need to uplift this to Aurora.
Orange :(
Attached patch Patch V1.1 (obsolete) — Splinter Review
Attachment #814786 - Attachment is obsolete: true
Attachment #814786 - Flags: review?(mratcliffe)
Attached patch Patch V2Splinter Review
I should not write code when I'm jetlagged.
Attachment #814848 - Attachment is obsolete: true
Attachment #814853 - Flags: review?(mratcliffe)
Comment on attachment 814853 [details] [diff] [review]
Patch V2

Review of attachment 814853 [details] [diff] [review]:
-----------------------------------------------------------------

Ah, a simple one.

The tiniest of tiny nits so feel absolutely free to completely ignore it ... you don't even need to read it ;o)

::: toolkit/devtools/server/tests/mochitest/test_styles-svg.html
@@ +5,5 @@
> +Bug 921191 - allow inspection/editing of SVG elements' CSS properties
> +-->
> +<head>
> +  <meta charset="utf-8">
> +  <title>Test for Bug </title>

Maybe <title>test_styles-svg.html</title>
Attachment #814853 - Flags: review?(mratcliffe) → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/56d35994adff
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
Hotness; thanks for fixing, Paul!
https://hg.mozilla.org/mozilla-central/rev/56d35994adff
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
will this be in 27? i’m currently missing this greatly…
(In reply to flying sheep from comment #14)
> will this be in 27? i’m currently missing this greatly…

Yes it will.
Duplicate of this bug: 922630
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.