Make disabled buttons look disabled

VERIFIED FIXED in Firefox 26

Status

defect
P1
normal
VERIFIED FIXED
6 years ago
Last year

People

(Reporter: jryans, Assigned: jryans)

Tracking

Trunk
Firefox 27

Firefox Tracking Flags

(firefox26 verified, firefox27 verified, b2g-v1.2 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Currently it's not very clear that disabled buttons are disabled, since they don't change in appearance.
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Attachment #810799 - Flags: review?(poirot.alex)
Comment on attachment 810799 [details] [diff] [review]
Make App Manager disabled buttons look disabled

Can you also do that for device.css? Don't use `cursor:not-allowed`. Use `pointer-events:none`.
Attachment #810799 - Flags: review?(poirot.alex)
Made all changes from previous review.
Attachment #810799 - Attachment is obsolete: true
Attachment #811204 - Flags: review?(paul)
Attachment #811204 - Flags: review?(paul) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3b45275a1eff
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
Comment on attachment 811204 [details] [diff] [review]
Make App Manager disabled buttons look disabled (v2)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: UI polish
Testing completed (on m-c, etc.): fx-team
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #811204 - Flags: approval-mozilla-aurora?
Priority: P2 → P1
Whiteboard: [waiting-for-aurora-approval]
Attachment #811204 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0

Verified as fixed on Fx 26 beta 3 (20131107161719) and latest Aurora (20131108004000) using Firefox OS 1.2 or 1.3 Simulator.
QA Contact: petruta.rasa
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.