Restore perf-spewer include files in js/src/jit

RESOLVED FIXED in mozilla27

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dougc, Assigned: dougc)

Tracking

unspecified
mozilla27
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

The jit/PerfSpewer.h include file appears to have
been removed from a few files in which it is still
necessary.  It is an optional build feature, but
quite useful for developers.
Attachment #811066 - Flags: review?(ehsan)
Comment on attachment 811066 [details] [diff] [review]
Restore perf-spewer include files in js/src/jit

Review of attachment 811066 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for breaking this.  :(

But looking at PerfSpewer.h, it only does something meaningful when JS_ION_PERF is #defined, which is why I didn't get build failures when I removed these includes.  Would you mind wrapping these three #includes in #ifdef JS_ION_PERF please?
Attachment #811066 - Flags: review?(ehsan) → review-
Found one more that needed restoring in x64/Trampoline-x64.cpp.

It was possible to conditionalize a few more instances.  Is
this the preferred style?

Tested x64 and x86 builds, with and without the perf feature
enabled.

Thank you for working to clean up the source.
Attachment #811066 - Attachment is obsolete: true
Attachment #811183 - Flags: review?(ehsan)
Attachment #811183 - Flags: review?(ehsan) → review+
Thanks!
Keywords: checkin-needed
Duplicate of this bug: 922188
https://hg.mozilla.org/mozilla-central/rev/3f5260dff279
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.