idls are not handled in --with-libxul-sdk builds.

RESOLVED FIXED in Firefox 26

Status

defect
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
mozilla28
Dependency tree / graph

Firefox Tracking Flags

(firefox26 fixed, firefox27 fixed, firefox28 fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [qa-])

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

6 years ago
There are a few idls in the app part of the build, and they are not handled in the --with-libxul-sdk case.
Assignee

Updated

6 years ago
Blocks: 911375, 884587
Assignee

Comment 1

6 years ago
Posted patch Partial patch for aurora (obsolete) — Splinter Review
This is a partial patch for aurora. This still fails on the following:
Traceback (most recent call last):
  File "../../../../config/pythonpath.py", line 56, in <module>
    main(sys.argv[1:])
  File "../../../../config/pythonpath.py", line 48, in main
    execfile(script, frozenglobals)
  File "../../../../python/mozbuild/mozbuild/action/xpidl-process.py", line 87, in <module>
    args.depsdir, args.module, args.idls)
  File "../../../../python/mozbuild/mozbuild/action/xpidl-process.py", line 43, in process
    idl.resolve([input_dir], p)
  File "/tmp/buildd/firefox-26.0~a2+20130928004001/build-xulrunner/dist/sdk/bin/xpidl.py", line 287, in resolve
    p.resolve(self)
  File "/tmp/buildd/firefox-26.0~a2+20130928004001/build-xulrunner/dist/sdk/bin/xpidl.py", line 257, in resolve
    raise IDLError("File '%s' not found" % self.filename, self.location)
xpidl.IDLError: error: File 'nsISupports.idl' not found, ../../../dist/idl/nsIFeedResultService.idl line 6:0
#include "nsISupports.idl"


That is, xpidl-process doesn't handle having an include directory for idls. That used to be handled by XPIDL_FLAGS, which were removed in bug 850380. I should have caught that during review.
Assignee: nobody → mh+mozilla
Assignee

Comment 2

6 years ago
Since I'm currently trying to build aurora packages, I have a patch for aurora first. Things changed significantly since for an m-c patch to require more work.
Attachment #811650 - Attachment is obsolete: true
Attachment #811663 - Flags: review?(gps)
Assignee

Updated

6 years ago
Attachment #811663 - Attachment is patch: true
Comment on attachment 811663 [details] [diff] [review]
Handle idls in --with-libxul-sdk builds (for beta)

Review of attachment 811663 [details] [diff] [review]:
-----------------------------------------------------------------

This looks sane.
Attachment #811663 - Flags: review?(gps) → review+
Assignee

Comment 4

6 years ago
Comment on attachment 811663 [details] [diff] [review]
Handle idls in --with-libxul-sdk builds (for beta)

This is for beta now ; Since I'm working on building aurora now, I guess I'll have a fix for m-c too.
Attachment #811663 - Attachment description: Handle idls in --with-libxul-sdk builds (for aurora) → Handle idls in --with-libxul-sdk builds (for beta)
Assignee

Comment 5

6 years ago
This is the variant for current aurora and m-c.
Attachment #826584 - Flags: review?(gps)
Attachment #826584 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/f2c1c0a02595
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Assignee

Comment 8

6 years ago
Comment on attachment 826584 [details] [diff] [review]
Handle idls in --with-libxul-sdk builds

[Approval Request Comment]
Bug caused by (feature/regressing bug #): a combination of bug 850380, bug 884587, bug 900330, and bug 911375
User impact if declined: building with --with-libxul-sdk fails (this option is used at least by fedora and debian).
Testing completed (on m-c, etc.): Landed on m-c a few days ago. I've used it on Debian for weeks.
Risk to taking this patch (and alternatives if risky):  It doesn't change any build behavior on mozilla.org builds. Only if --with-libxul-sdk is used.
String or IDL/UUID changes made by this patch: None
Attachment #826584 - Flags: approval-mozilla-aurora?
Assignee

Comment 9

6 years ago
Comment on attachment 811663 [details] [diff] [review]
Handle idls in --with-libxul-sdk builds (for beta)

[Approval Request Comment]
See the other approval in the same bug. This is a variant of the patch for beta. I've used it for even longer than the other patch, except that since i didn't have a patch to land on m-c yet, it had to wait.
Attachment #811663 - Flags: approval-mozilla-beta?
Attachment #826584 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #811663 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whiteboard: [qa-]

Updated

a year ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.