view source on FTP url offers to download

RESOLVED DUPLICATE of bug 86835

Status

Core Graveyard
View Source
RESOLVED DUPLICATE of bug 86835
17 years ago
8 years ago

People

(Reporter: dbaron, Assigned: Doron Rosenberg (IBM))

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
view source on an FTP url offers to download the file.

steps to reproduce:
 * load ftp://ftp.mozilla.org/README
 * View | Page Source

actual results:
 * view source window opens
 * two assertions about channel not having a prompt
 * a download dialog comes up asking me whether I want to download a file of
type application/x-unknown-content-type; x-view-type=view-source

expected results:
 * view source shows the same thing as is in the browser window (since it's a
text file; would be different for HTML)

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Comment 1

17 years ago
View source should NOT be available on a FTP site IMHO
What would you expect to see, a listing of the files? That's the same as the
main ftp window! I think that would be redundant
(Reporter)

Comment 2

17 years ago
This bug is NOT about view-source for FTP directory listings.  It's about
view-source for FTP files, which can be HTML, although we do view-source
correctly for HTML, it seems:
ftp://geo.msfc.nasa.gov/Weather/weather.html
just not
ftp://ftp.mozilla.org/README

Comment 3

17 years ago
Oooh, i see what you mean.
Maybe we should just enable that for html, because i went over a page that when
you click on it , it opened up a window with supposedly html, and i click on
view source and it said that it was a jpg file and if i wanted to download it
Dup of bug 77337 (or perhaps 76816, which is closely related)

*** This bug has been marked as a duplicate of 77337 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
VERIFIED: Dupe
same problem, based on data in various comments here.
Status: RESOLVED → VERIFIED

Comment 6

16 years ago
REOPEN:
+testcase
Nah, now a depends, so I can test this when it is fixed.
updated URL w/ another file that breaks.
Status: VERIFIED → REOPENED
Depends on: 77337
Keywords: testcase
Resolution: DUPLICATE → ---

Comment 7

16 years ago
doron@netscape.com, maybe you have time to look at this one?  If not toss back
to me.
Assignee: dougt → doron
Status: REOPENED → NEW
Component: Networking: FTP → ViewSource
Target Milestone: mozilla1.0 → ---
(Assignee)

Comment 8

16 years ago
I have no idea about that part of the backend - bz?
I fixed this a while back, methinks.  See bug 86835.  The URL in the URL field
worksforme...

Please retest?

Comment 10

16 years ago
qa to me. 
wfm Win32, Mozilla 1.1b.
joy, let me guess, viewsource is basically its own protocol handler now, based
on what I read in the other bug.

So is this a dupe of that bug?
QA Contact: tever → benc
Yes, it is.

*** This bug has been marked as a duplicate of 86835 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: benc → pmac
Product: Browser → Seamonkey

Updated

8 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.