Closed Bug 921904 Opened 6 years ago Closed 6 years ago

After having canceled downloading, 0 bytes file stays in the download folder

Categories

(Firefox :: Downloads Panel, defect)

26 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 918466

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/8f805d3ef377
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130929030202

Steps To Reproduce:
1. Start Firefox with new profile
2. Ex.
   Open http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
   And Click firefox-27.0a1.en-US.linux-i686.tests.zip
3. Choose "Save file" and click OK in helper dialog.
4. When start downloading, click Downloads-indicator icon if "Download panel" is hidden.
   And click x button to cancel the download.
5. Open download folder  
   --- observe 0bytes file
  
Actual Results:
"firefox-27.0a1.en-US.linux-i686.tests.zip  0bytes" file stays in the download folder

Expected Results:
0 bytes file should not stay.

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/764ac2c7cb0a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130820015126
Bad:
http://hg.mozilla.org/mozilla-central/rev/d8b7195b63c9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130820015423
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=764ac2c7cb0a&tochange=d8b7195b63c9

Regression window(fx-team)
Good
http://hg.mozilla.org/integration/fx-team/rev/b7f636fada9f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130819140640
Bad:
http://hg.mozilla.org/integration/fx-team/rev/c2b4444ad9fd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130819144040
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=b7f636fada9f&tochange=c2b4444ad9fd

Regresseed by: Bug 847863
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 918466
You need to log in before you can comment on or make changes to this bug.