m.r7.com can’t play a video

RESOLVED INVALID

Status

Tech Evangelism
Mobile
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: efrat, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [serversniff][country-br][sitewait][video], URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.76 Safari/537.36

Steps to reproduce:

Browsed to "http://m.r7.com/universalizationLayer/m/t/videos" from Gaia browser

Tested on: 
User Agent String: Mozilla/5.0 (Mobile; rv:27.0) Gecko/27.0 Firefox/27.0

Model: nice
Software: Boot2Gecko 1.3.0.0-prerelease
Platform Version: 27.0a1
Build identifier: 20130928030636
Update channel: default


Actual results:

The site loads but browser is stuck and cannot play video, followed by the message: "Video can't be played because the file is corrupt"



Expected results:

The web page should have been displayed correctly for mobile 
Displays correctly on Firefox for Android and Chrome for Android
(Reporter)

Updated

4 years ago
Interesting, I can't get it to play on Chrome for Android or Firefox for Android. I get either the following message in both:

"Desculpe-nos. Vídeos disponíeis apenas para iOS e Androids." (Forgive us. Videos are only available for iOS and Android). 

Or sometimes I get an Access Denied message.

When clicking on a video from the Android stock browser I get an intent to either download or play the video in a media player.

It seems like there's some sniffing logic on the server that is falling over.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [serversniff][country-br][contactready]
Testing this again, I'm able to play the videos in Firefox for Android (nightly) without a problem but still get the "sorry videos are only available for Android and iOS" message.

Looking for a contact now.
Attempting contact through this form: http://www.r7.com/institucional/comunicar-erro/index.html
Whiteboard: [serversniff][country-br][contactready] → [serversniff][country-br][sitewait]
Whiteboard: [serversniff][country-br][sitewait] → [serversniff][country-br][sitewait][video]
Depends on: 826510
This site is somewhat odd - I can play some videos (i.e. http://m.r7.com/universalizationLayer/m/p/5889_1538844_908.htm ). Most videos just apologise for "only" being available on iOS and Android - but here's the thing: Android stock browser, Firefox on Android and Firefox OS browser play the same videos and fail to play the same videos! If a video says it's not available, the same message appears for that video even in the Android stock browser.

Invalid? If we can find a video that *does* play in Android stock or iOS but not in Firefox, we should contact them. If not, we can close it. Seems they serve the same stuff across the board..

Comment 5

4 years ago
I tried to find videos without success. :) It will be reopened if someone has a case.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.