Closed Bug 922031 Opened 8 years ago Closed 8 years ago

[regression] Trusted UI transitions are broken

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:-)

RESOLVED WORKSFORME
blocking-b2g -

People

(Reporter: ferjm, Assigned: alive)

References

Details

(Whiteboard: [FT:System-Platform])

The trusted UI is not working as it should in general :(.

1. There is some weird flickering showing the opener app content within the trusted UI when the HOME button is clicked while the dialog is being shown.

2. We end up embedding the opener app content within the trusted UI (instead of the appropriate hosted flow, Persona in this case) when the app is chosen via the task switcher.

I wonder if this is a regression from recent System app refactors.

I've uploaded a video of the issue to https://vimeo.com/75758810
Looks like the visibility of opener is not correctly set.
But I don't have idea about the second one now. Taken first.
Assignee: nobody → alive
I suggest not to rush into this:
The trustedUI is hacking window manager now, to toggle the homescreen or set the visibility of app frame directly.
I'd like to implement bug 911880 to totally resolve this (the bad transition).

However I could try to see if there's a workaround at first.
Thanks Alive.

It's also happening in v1-train, so I'm setting the koi? flag.
blocking-b2g: --- → koi?
(In reply to Fernando Jiménez Moreno [:ferjm] (needinfo, please) from comment #3)
> Thanks Alive.
> 
> It's also happening in v1-train, so I'm setting the koi? flag.

Sounds not a regression from my work :)
(In reply to Fernando Jiménez Moreno [:ferjm] (needinfo, please) from comment #3)
> Thanks Alive.
> 
> It's also happening in v1-train, so I'm setting the koi? flag.

If it already happening on v1-train, didn't you mean to set leo?

Anyways, it might be too late to get this into 1.1 at this point.
(In reply to Jason Smith [:jsmith] from comment #5)
> (In reply to Fernando Jiménez Moreno [:ferjm] (needinfo, please) from
> comment #3)
> > Thanks Alive.
> > 
> > It's also happening in v1-train, so I'm setting the koi? flag.
> 
> If it already happening on v1-train, didn't you mean to set leo?
> 
> Anyways, it might be too late to get this into 1.1 at this point.

Agree v1.1 is too late to do anything and this part is sensible enough.
BTW, this won't affect usage so it's not blocking IMO.
(In reply to Alive Kuo [:alive] from comment #6)
> (In reply to Jason Smith [:jsmith] from comment #5)
> > (In reply to Fernando Jiménez Moreno [:ferjm] (needinfo, please) from
> > comment #3)
> > > Thanks Alive.
> > > 
> > > It's also happening in v1-train, so I'm setting the koi? flag.
> > 
> > If it already happening on v1-train, didn't you mean to set leo?
> > 
> > Anyways, it might be too late to get this into 1.1 at this point.
> 
> Agree v1.1 is too late to do anything and this part is sensible enough.
> BTW, this won't affect usage so it's not blocking IMO.

Yes, it's too late for leo, that's why I asked for koi.

It affects usage if the app is embedded within the trusted UI (issue 2 from comment 0) and it provides a very confusing UX.
blocking-b2g: koi? → 1.3?
Not blocking the Firefox Accounts work anymore, since we won't be using the Trusted UI for this flow.
No longer blocks: fxos-accounts
Whiteboard: [FT:System-Platform]
Please help to check if this one has been fixed. Tim tried the latest build but cannot reproduce it.
Keywords: qawanted
blocking-b2g: 1.3? → -
Component: Gaia::System → Gaia::System::Window Mgmt
(In reply to Ivan Tsay (:ITsay) from comment #9)
> Please help to check if this one has been fixed. Tim tried the latest build
> but cannot reproduce it.

if this is true, I'm going to close this as a wfm, as that implies this works on 1.3 & 1.4.
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.