Back menu item moves if in frame

RESOLVED DUPLICATE of bug 27338

Status

RESOLVED DUPLICATE of bug 27338
17 years ago
14 years ago

People

(Reporter: bugzilla20071228, Assigned: mpt)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2+) Gecko/20010720
BuildID:    2001072021

Whem using the RMB (right mouse button) in a normal page, the first item listed
is the 'Back' item but when using it in a frame, the first item listed is 'Open
Frame in New Window' and the 'Back' item is now the third item listed.

Reproducible: Always
Steps to Reproduce:
1.Go to a frame-free site, check the RMB menu order
2.Go to a site with frames and check the RMB menu order


Actual Results:  The 'Back' menu item got shifted to 3rd place.

Expected Results:  The 'Back' menu item to have stayed put in 1st place.

This is bad for a simple reason. You get used to the back buttom being the first
item there and so you start using it mindlessly (ie you don't look anymore, you
expect it to be there). Then you hit a page with a frame, hit the RMB and select
the first item and a new window opens. The 'Back' item is now the third in the
list. Very annoying to say the least.

I'd recommend examining which items get used the most in this menu and keeping
them put. At a guess (and from my experience) sticking as close to the order in
the default RMB menu as possible (esp with the top items) would be the best way
to go.
Marking as dupe.

*** This bug has been marked as a duplicate of 27338 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.