Create integration tests for notification events

RESOLVED DUPLICATE of bug 967475

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 967475
4 years ago
4 years ago

People

(Reporter: qdot, Assigned: qdot)

Tracking

unspecified
2.0 S2 (23may)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 1 obsolete attachment)

We break events a lot when changing notifications. It'd be nice to know if we did.
Created attachment 812387 [details] [diff] [review]
Patch 1 (v1) - WIP (links to branch) - Implement notification event integration tests
Blocks: 925160
Blocking on Bug 899574 since mhenretty has some additions and fixes to make to notification tests.
Depends on: 899574
Created attachment 824233 [details]
Patch 1 (v2) - WIP (links to branch) - Implement notification event integration tests

Continuing WIP. Setting onclose after getting notification back from .get() in close() doesn't seem to work, while setting it as part of create() does.
Attachment #812387 - Attachment is obsolete: true
Attachment #824233 - Attachment mime type: text/plain → text/x-github-pull-request
Depends on: 932929
Whiteboard: [systemsfe]
Target Milestone: --- → 1.4 S1 (14feb)
Target Milestone: 1.4 S1 (14feb) → ---
The tests coming in with bug 967475 basically fix this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → 2.0 S2 (23may)
Duplicate of bug: 967475
You need to log in before you can comment on or make changes to this bug.