Closed Bug 922456 Opened 6 years ago Closed 6 years ago

Defect - GFX issues when moving between different views (Full, Filled & Snapped)

Categories

(Firefox for Metro Graveyard :: Browser, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: kjozwiak, Assigned: jimm)

References

Details

(Whiteboard: [block28] feature=defect c=Browser_views u=metro_firefox_user p=2)

Attachments

(3 files)

When moving between full, filled & snapped views while on the awesome screen on my Desktop machine, I constantly run into the following issues:

- Black area when dismissing the snapped view area rather then filling out properly into full view
- "Top Sites" squished with all the other menu's missing rather then returning to the correct full view

I attached two screenshots to illustrate the issue

Steps to reproduce the issue #1:

1) Open Firefox Metro
2) Once on the awesome screen (it should be completely clean), slide in the Desktop into snapped view
3) Slide in the desktop snapped view into filled view (Firefox Metro should be in snapped view)
4) Move the Firefox Metro into full view and you'll notice that the awesome screen will not return into its normal full view

Steps to reproduce the issue #2:

1) Open Firefox Metro
2) Once on the awesome screen is visible, slide in the Desktop into snapped view
3) Slide the awesome screen into full view and you should see a black area where the snapped desktop view used to be

Current Behavior:

- When moving around in full, filled and snapped view, you'll notice some graphical UI issues (black area's, stretched screens)

Expected Behavior:

- Everything should be returned into the correct view without any visible graphical UI issues

Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-09-30-03-02-05-mozilla-central/
Whiteboard: feature=defect c=Browser_views u=metro_firefox_user p=0 → [triage] feature=defect c=Browser_views u=metro_firefox_user p=0
Ran into a similar issue on a different machine (Lenovo X1 Carbon). Was transitioning between filled & snapped view and ran into a graphical UI issue similar to the one described in comment #0.

- Attached a screenshot to illustrate the issue on this machine
Whiteboard: [triage] feature=defect c=Browser_views u=metro_firefox_user p=0 → feature=defect c=Browser_views u=metro_firefox_user p=0
I can only reproduce this when I go into snapped-view, use the scrollbar, then restore to full view. Without any scrolling in-between the transition is smooth
Hi Kamil, can you test to see if you are still experiencing this.
Flags: needinfo?(kamiljoz)
Whiteboard: feature=defect c=Browser_views u=metro_firefox_user p=0 → [block28] feature=defect c=Browser_views u=metro_firefox_user p=0
Think Sam is correct, usually very reproducible when some type of scrolling is involved. If you move into a different view (Snapped, Filled) and scroll through the website, moving it back to "Full View" will sometimes replace some of the website with "white" or "black" area's. Sounds similar to some of the other issues were "black" bars appear at the top when scrolling, this appears at the sides when changing views.

Using the following STR, I can reproduce that problem pretty consistently but is not as bad as before (also fixes itself as soon as you scroll):

1) Open Firefox Metro
2) Slide in the Desktop over Firefox Metro
3) Slide in Firefox Metro and place it into "Snapped View"
4) Move Firefox Metro into "Filled View"
5) Move Firefox Metro into "Full View". You should notice a black area where Firefox Metro was in "Snapped View" originally
6) Scroll through the awesome screen and the black area will disappear

Used the Carbon X11 as the testing device, using the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-10-28-03-02-05-mozilla-central/
Flags: needinfo?(kamiljoz)
Depends on: 937626
(In reply to Kamil Jozwiak [:kjozwiak] from comment #5)
> 1) Open Firefox Metro
> 2) Slide in the Desktop over Firefox Metro
> 3) Slide in Firefox Metro and place it into "Snapped View"
> 4) Move Firefox Metro into "Filled View"
> 5) Move Firefox Metro into "Full View". You should notice a black area where
> Firefox Metro was in "Snapped View" originally
> 6) Scroll through the awesome screen and the black area will disappear

http://www.gutenberg.org/files/11/11-h/11-h.htm

I see a temporary redraw problem doing this on pages with background colors, but I don't see a lasting problem that requires scroll to reset it.

We've landed a few resize fixes, would you mind re-confirming kamil and let me know what you get currently?
Actually, please wait until tomorrow, bug 934762 still hasn't made it to mc.
Flags: needinfo?(kamiljoz)
Assignee: nobody → jmathies
Whiteboard: [block28] feature=defect c=Browser_views u=metro_firefox_user p=0 → [block28] feature=defect c=Browser_views u=metro_firefox_user p=2
Blocks: metrov1it20
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Went through a bunch of test cases (listed below) including the original one from comment #0 and couldn't reproduce the issue. I used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-11-27-03-02-01-mozilla-central/

This bug was originally found and reproduced on Windows 8. Unfortunately I only have Windows 8.1 now and can't go through this issue using the original OS. Jim, since Windows 8.1 changed how the views behave, should this be tested in Windows 8 just to double check and make sure that the issue is fixed on there? I also noticed that you'll see a "white space" when resizing but it will get filled in pretty quickly, it is noticeable though.

Test Cases used (Windows 8.1):

- Used several websites that have a background color including the one listed in comment #6
- Swiped between Firefox Metro and Windows Desktop several times (slowly and fast)
- When Firefox Metro and the Windows Desktop used the split screen (50-50), started to increase the Firefox Metro screen a few increments at a time until the Windows Desktop transitioned into "Snapped View" (did this a few times back and forth, increasing Firefox Metro and then increasing Windows Desktop)
- When Firefox Metro and the Windows Desktop used the split screen (50-50), started to increase the Firefox Metro screen in large increments (did this a few times back and forth, increasing Firefox Metro and then increasing Windows Desktop)
- Quickly swiped in the Windows Desktop once Firefox Metro was loading an intensive webpage and then quickly swiped back the Firefox Metro back into view
- When Firefox Metro and the Windows Desktop used split screen, slowly decreased the size of Firefox Metro until it disappeared and Windows Desktop transitioned to the main view. Once this happened, I quickly swiped the Firefox Desktop into view (did this back and forth between Firefox Metro and the Windows Desktop)
- I also went through the above test cases using other applications (Evernote Touch, Mail, Khan Academy)

Went through all of the above test cases including the original for about an hour and couldn't reproduce the issue.
Flags: needinfo?(kamiljoz)
Thanks Kamil!
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.