[rfe] backspace should page up

VERIFIED DUPLICATE of bug 36922

Status

()

P5
enhancement
VERIFIED DUPLICATE of bug 36922
18 years ago
17 years ago

People

(Reporter: blizzard, Assigned: aaronlev)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

18 years ago
In Netscape 4.x space would page down and Backspace would page up.  Mozilla
doesn't do this.
-> Keyboard navigation
Assignee: asa → aaronl
Component: Browser-General → Keyboard Navigation
QA Contact: doronr → sairuh
(Assignee)

Comment 2

18 years ago
Oh God, please don't engage in another philosophical debate about this stuff.
I don't care. 


Bug 69981 was just fixed so that backspace doesn't go back a page.
Summary: delete should page up → [rfe] backspace should page up
Severity: normal → enhancement

Comment 3

18 years ago
just because 4.x did it, and just because it is another feature does not make it
a good idea. Backspace is designed to do just that, delete back a space. Making
it do something the user is not accustomed to isn't right. Granted, its not as
bad as going back a page (and risking losing data) but it still is unnecessary. 

Page up and Page down functions are built into the keyboard already. That's what
the "Page Up" and "Page Down" buttons are for.

With that said, if we *need* to map backspace to something (lets map every key
to some function!) This functionality would be the least obnoxious way to go.
Mike, there are other programs on Unix that use backspace to page up.  gv comes
to mind right away, and I'm sure there are others as well..

So of the 4 progams I use most (shell, editor, browser, postscript viewer) two
actually need to have backspace delete text and the other two use it to page
up....

Comment 5

18 years ago
What about RFE bug 79047 ('Shift + Space' should scroll upwards)?

If shift+tab tabs focus backwards, shouldn't shift+space page up?
(Reporter)

Comment 6

18 years ago
Space/Backspace are common neumonics as opposites both on windows and unix. 
Shift-space isn't.

Comment 7

18 years ago
According to the comments in bug 79047, shift+space is the common mneumonic 
opposite space on the Mac.  On Windows, any program using the IE widgit uses 
this mnemonic too.

When it comes to comprehensive UI design, I trust MacOS and Windows over UNIX 
any day.
(Reporter)

Comment 8

18 years ago
That's why each one is in the platform-specific bindings. :)
(Assignee)

Comment 10

18 years ago
Reassigning to German/UI design to sort this out.
Assignee: aaronl → german
OS: Linux → All

Comment 11

17 years ago
As a unix person, I was surprised when backspace was ignored.  Count
me in as someone who wants backspace to go back a page.

Austin

Comment 12

17 years ago
In addition to paging back in my trusty Netscape 4.75/Linux and its Windows
brethen, backspace has navigational value of "back" in two other rather major
pieces of Microsoft browsing software: Intenet Explorer and the Explorer shell.
 Backspace should definitely page up.  I'm lazy, and its not as far to reach on
my keyboard; I can hit backspace without moving my hands from over the home keys
by moving my pinky.  ;-P
*** Bug 98509 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
In case it counts, I'd like to cast another "vote" for backspace scrolling up. 
On Unix, THE precedent for space/backspace scrolling down/up is Emacs, where all
the non-self-insert modes, such as info and w3, behave like that.

Space and backspace are much easier to reach than PgUp and PgDn.  That is why I
almost always scroll down with space, and get "stuck" when backspace doesn't work.

Because of these things, backspace scrolling up, at least on Unix, is not just a
perversity on the part of Netscape designers -- it's a feature many users have
come to expect.  Also, it wasn't a novelty in 4.x; as far as I remember, most
Netscape versions since about 1.1 behaved that way (sometimes they would screw
it up in betas.)

Comment 15

17 years ago
This missing key binding is driving me INSANE.  Is there a configuration file
which can be editted by hand to add this key binding to Mozilla?  A HOWTO for
adding the key binding would at least give users familiar with it the option of
turning it on.

Comment 16

17 years ago
I've figured out how to do this.  I hope that me publishing this won't lessen
the chance of this key binding becoming standard, because I would really like that.

Until that happens, you need to create a `userHTMLBindings.xml' file.  This file
resides in the res/builtin/ directory in the Mozilla tree (the place where you
installed the Mozilla binaries; *not* ~/.mozilla/).

For backspace to scroll up, the file should contain the following:

<?xml version="1.0"?>

<!-- In order to work correctly, this file must live in the -->
<!-- res/builtin directory of the mozilla tree. -->

<bindings id="htmlBindings"
   xmlns="http://www.mozilla.org/xbl"
   xmlns:xul="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

<binding id="browserUser">
<handlers>
<handler event="keypress" keycode="VK_BACK" command="cmd_scrollPageUp"/>
</handlers>
</binding>

</bindings>
->aaronl, since german is no longer here...and i'm not sure which UI person
should own keybd nav stuff for the browser.
Assignee: german → aaronl
(Assignee)

Comment 18

17 years ago
Taking, but I'm not going to do it until it's been proven that most people want
this, since there are so many people against it.
Status: NEW → ASSIGNED
Priority: -- → P5
Target Milestone: --- → Future

Comment 19

17 years ago
just a fyi, Opera also sports backspace navigation.  

It is my opinion that backspace on Windows/Linux should also page back to the
previous category heading (folder) in lists.  For example in bookmarks, if you
have categories like:

[+] News
[-] Entertainment
      Movies
      Music
[-] Shopping
      Cars
      Books
  --- Frogs ---
      
If "Frogs" is selected, hitting backspace will take the selection to "Shopping"
directly, hitting it again will highlight "Entertainment", once more will take
you to "News".   

After miles of drilling down into heavily categorized bookmarks, this would help
you get back out quickly.

(Assignee)

Comment 20

17 years ago
Marlon, are you asking the backspace do what left arrow does now?

Can you find any other apps that support backspace this way?

Comment 21

17 years ago
well kinda. it's a common windows convention, look anywhere. you can find it on
IE, and most lists in the OS.  I suppose what i meant was something more like this:

[-] Marlon's Bookmarks
   [+] News
   [-] Entertainment
      [-] Movies
            Harry Potter
            Matrix
         Music
   [-] Shopping
         Cars
         Books
     [-] Frogs
            Carnivores
        --- Herbivores ---


Backspacing would not take you up to each preceding category, but up to the
*parent* category.  The backarrow, as you suggested, takes you simply to the
previous category/folder.   

With Backspace you get: Frogs, Shopping, Marlon's Bookmarks
With Backarrow you get: Frogs, Shopping, Entertainment, News, Marlon's Bookmarks

Comment 22

17 years ago
i've never met a backarrow or a forward arrow.

On windows (in a tree view) left arrow will:
if (object.has.children)
then
 collapse(object)
else
 go_to(object.parent)

On windows backspace is like left arrow except that the if (condition) is always
evaluated as false ...

go_to(object.parent)

The idea of backspace navigating a page hierarchically might be interesting.
Since it wouldn't duplicate functionality ...
(Assignee)

Comment 23

17 years ago
Created attachment 55361 [details] [diff] [review]
This patch should work but doesn't, perhaps due to bug 50255?
(Assignee)

Updated

17 years ago
Attachment #55361 - Attachment is obsolete: true

Comment 24

17 years ago
The patch should probably be Windows-only unless there's evidence that a
significant number of users on other platforms want it.  I know there are a
significant number of Unix users who don't want it ...  and it's easy for people
who want this binding to add it in their own user bindings, but it's not clear
that it's easy for users who don't want it to turn it off (not sure if disabling
user bindings currently works or not).

Comment 25

17 years ago
This long time Unix user defintely wants that key binding (thanks for the HOWTO,
Hrvoje, worked perfectly!).  It's been there in every version of Netscape I've
ever used and I don't expect it to disappear in Mozilla.

(Reporter)

Comment 26

17 years ago
I know lots of unix users who do want it.

Comment 27

17 years ago
reminder - do not implement on mac please :)  we have a delete button in the
backspace location
(Assignee)

Comment 28

17 years ago
Created attachment 55662 [details] [diff] [review]
Backspace page up for windows and linux
Aaron, have you tested that this does not break Flash forms?  In such forms,
backspace should delete as it does in Mozilla forms.
(Assignee)

Comment 30

17 years ago
Nope. Since it's such a political bug, I'd like to leave it to someone who
really wants it fixed to test it and get it reviewed.

Comment 31

17 years ago
*** Bug 107632 has been marked as a duplicate of this bug. ***

Comment 32

17 years ago

*** This bug has been marked as a duplicate of 36922 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.