We shouldn't use "dialog" as a global variable. Instead we should use something more specific to Composer. I suggest "gComposerDialog" but something similar would be fine as well. On a related note, if someone were to convert all of the dialogs into floating palettes, would the JS still work or do we need each dialog to have its own global variable (gImageDialog, gTableDialog, gHRuleDialog, etc.)? I'd prefer going with names like these instead of sharing "gComposerDialog" if that is possible.
I'd like to avoid "gComposerDialog". It is repeated many times in each dialog, and I'd like to keep down the number of characters. The variable is global to that specific instance of the dialog, so I don't there's a problem. How about "gEdDialog" or "gEdDlg" instead?
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.4
if it's global to a specific instance, how about gImageDlog, gTableDlog, gHRuleDlog, GAnchorDlog, gInsTableDlog, gInsHTMLDlog, etc?
Ok, nothing wrong with that strategy.
moving out to 0.9.6
Target Milestone: mozilla0.9.5 → mozilla0.9.6
spam composer change
Component: Editor: Core → Editor: Composer
Moving all simple fixes that touch many dialogs to bug 93732. *** This bug has been marked as a duplicate of 93732 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.