Closed Bug 922611 Opened 8 years ago Closed 8 years ago

Avoid dock repainting while swiping from second to first page

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:-)

RESOLVED FIXED
blocking-b2g -

People

(Reporter: crdlc, Assigned: crdlc)

Details

(Keywords: perf)

Attachments

(1 file)

No description provided.
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
blocking-b2g: --- → koi?
Attached file Patch v1
Attachment #812616 - Flags: review?(ran)
Attachment #812616 - Flags: review?(ran) → review+
https://github.com/mozilla-b2g/gaia/commit/011836c8d6fd840424dc04b011512247d9580325
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 812616 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: better performance panning first pages
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]:
Attachment #812616 - Flags: approval-gaia-v1.2?
Keywords: perf
Whiteboard: [koi-]
Not a blocker for release, but feel free to get approval.
blocking-b2g: koi? → -
Whiteboard: [koi-]
Attachment #812616 - Flags: approval-gaia-v1.2? → approval-gaia-v1.2+
I was not able to uplift this bug to v1.2.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.2, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.2
  git cherry-pick -x -m1 011836c8d6fd840424dc04b011512247d9580325
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(crdlc)
Sorry but this patch cannot be merged in v1.2 because it only made sense for the new features of ev.me what won't be landed on v1.2 (finally for v1.3)
Flags: needinfo?(crdlc)
Comment on attachment 812616 [details]
Patch v1

Clearing approval per above comment.
Attachment #812616 - Flags: approval-gaia-v1.2+
You need to log in before you can comment on or make changes to this bug.