Closed Bug 922835 Opened 6 years ago Closed 6 years ago

debugger gives weird exception

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 27

People

(Reporter: dmose, Assigned: fitzgen)

Details

(Whiteboard: [chrome-debug])

Attachments

(3 files)

Attached image skitch.png
I suspect this bug report won't have detail, as I was trying to find a script in the social API, and ended up stopped on a breakpoint that didn't seem to be set, and then continued.  In other words, I have no idea what the steps to reproduce are.  HOWEVER, I did have debugger logging turned on, and I got an error message and a stack.

So in case it's possible to deduce a real bug by looking at this stack and error, I'm attaching it to this message.
Whiteboard: [chrome-debug]
This is Nightly:

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:27.0) Gecko/20100101 Firefox/27.0

And about:buildconfig says it was build from:

http://hg.mozilla.org/mozilla-central/rev/6b92cb377496
Whiteboard: [chrome-debug]
This was while using the Browser Debugger on content code in the SocialAPI chat window, FWIW.
FYI, we use [chrome-debug] for all browser debugger bugs (as opposed to the "normal" content page debugger that is inside the toolbox).
Whiteboard: [chrome-debug]
Assignee: nobody → nfitzgerald
Attached patch bug-922835.patchSplinter Review
Changes this.youngestFrame to a getter based on dbg.getNewestFrame(), makes getFrameLocation handle null inputs.

Since we don't have STR, I can't verify that this fixes the issue, but I think it is a good change to have.

https://tbpl.mozilla.org/?tree=Try&rev=6af9411614b6
Attachment #813991 - Flags: review?(past)
Comment on attachment 813991 [details] [diff] [review]
bug-922835.patch

Review of attachment 813991 [details] [diff] [review]:
-----------------------------------------------------------------

Please remove the XXX comment at line 1184 as well.
Attachment #813991 - Flags: review?(past) → review+
Priority: -- → P3
https://hg.mozilla.org/integration/fx-team/rev/6de71ba24d50
Whiteboard: [chrome-debug] → [chrome-debug][fixed-in-fx-team]
Backed out because I pushed a version of the patch that would cause failures.

https://hg.mozilla.org/integration/fx-team/rev/71d3897f3ba8
Whiteboard: [chrome-debug][fixed-in-fx-team] → [chrome-debug]
Re-landed: https://hg.mozilla.org/integration/fx-team/rev/c52358389897
Whiteboard: [chrome-debug] → [chrome-debug][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/c52358389897
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [chrome-debug][fixed-in-fx-team] → [chrome-debug]
Target Milestone: --- → Firefox 27
> (!this.state == "paused")

This should have been (this.state != "paused"). It's a harmless bug though.
Attached patch typo.patchSplinter Review
Woopsie.
Attachment #8356273 - Flags: review?(rcampbell)
Attachment #8356273 - Flags: review?(rcampbell) → review+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.