xpcshell not working with MOZ_PSEUDO_DERECURSE skipping

RESOLVED FIXED in mozilla27

Status

Firefox Build System
General
RESOLVED FIXED
5 years ago
5 months ago

People

(Reporter: gps, Assigned: glandium)

Tracking

Trunk
mozilla27

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
My xpcshell binary fails to start with MOZ_PSEUDO_DERECURSE set to 1. Add no-skip works around the problem.

The binary starts, then exits immediately with a 1 exit code.
(Reporter)

Comment 1

5 years ago
Created attachment 813079 [details] [diff] [review]
tree-diff

Look like .xpt files aren't getting installed (among other things).
(Assignee)

Comment 2

5 years ago
Created attachment 813086 [details] [diff] [review]
XPIDL_SOURCES impacts the libs tier

I thought all the xpt stuff was done with install manifests. It's not. Installing in dist/bin is still done in rules.mk, presumably because of FINAL_TARGET.

It would be interesting to see why your "bad" build has some files that the other doesn't.
Attachment #813086 - Flags: review?(gps)
(Assignee)

Updated

5 years ago
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
(Reporter)

Comment 3

5 years ago
Comment on attachment 813086 [details] [diff] [review]
XPIDL_SOURCES impacts the libs tier

Review of attachment 813086 [details] [diff] [review]:
-----------------------------------------------------------------

We abandoned doing the xpt foo properly because it was just beyond the pain threshold for the bug. Now that we have dist/bin under manifest control, it's very tempting to just do that now.
Attachment #813086 - Flags: review?(gps) → review+
(Assignee)

Comment 4

5 years ago
(In reply to Gregory Szorc [:gps] from comment #3)
> We abandoned doing the xpt foo properly because it was just beyond the pain
> threshold for the bug. Now that we have dist/bin under manifest control,
> it's very tempting to just do that now.

I don't think that's possible until FINAL_TARGET can be computed in recursivemake.py.
(Reporter)

Comment 5

5 years ago
Yep. I filed bug 923080 with the proper dependency on FINAL_TARGET.
cc-ing sworkman. He met me yesterday while he debugging an XPCshell bustage that looked to happen with incremental build, but *not* happen with same changeset with a clobber build.
(Reporter)

Comment 8

5 years ago
(In reply to John O'Duinn [:joduinn] from comment #7)
> cc-ing sworkman. He met me yesterday while he debugging an XPCshell bustage
> that looked to happen with incremental build, but *not* happen with same
> changeset with a clobber build.

You shouldn't have seen this failure in automation: only on local builds that have opted in to MOZ_PSEUDO_DERECURSE. And, the regression range for this bug was only a few hours on inbound. I highly doubt you hit this.
https://hg.mozilla.org/mozilla-central/rev/497bf9a9cd64
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.