WebGL rendering issues on Linux

NEW
Unassigned

Status

()

Core
Canvas: WebGL
5 years ago
5 years ago

People

(Reporter: pauly, Unassigned)

Tracking

(Depends on: 1 bug)

25 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 813080 [details]
Screenshot

I see a strange black triangle when playing Epic Citadel on Ubuntu 13.04 x64, FF 25b4.
Video card: ATI Radeon 3000
(Reporter)

Comment 1

5 years ago
Reproducible on FF 23.0.1
(Reporter)

Comment 2

5 years ago
Linux specific only.
(Reporter)

Comment 3

5 years ago
Reproducible on FF 26.0a2(2013-10-01), 27.0a1(2013-10-01), Ubuntu 13.04 x64.
Strange I couldn't reproduce on another machine with Ubuntu 12.10 x86.
So it's either video card or x86/x64 related. I'll dig further.
(Reporter)

Comment 4

5 years ago
(In reply to Paul Silaghi [QA] from comment #3)
> Strange I couldn't reproduce on another machine with Ubuntu 12.10 x86.
That was with NVIDIA card.

> So it's either video card or x86/x64 related.
On another machine (Ubuntu 13.04 x86) with ATI Radeon HD 5450, FF closed unexpectedly while loading the game. So, I would say there is something wrong with webGL on ATI cards.
Paul, please try to find a more narrow regression window for this bug.
(Reporter)

Comment 6

5 years ago
On FF <= 16, the game won't run.
Starting with FF 17, this bug is reproducible.
So, doesn't seem to be a regression.
Trying again, I couldn't reproduce this issue on any other machine, so I guess the impact isn't that big.
You need to log in before you can comment on or make changes to this bug.