multiple edit message filters crashes

VERIFIED DUPLICATE of bug 90208

Status

MailNews Core
Backend
--
critical
VERIFIED DUPLICATE of bug 90208
17 years ago
10 years ago

People

(Reporter: Bruce Ingalls, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.2+) Gecko/20010725
BuildID:    2001072508

If I try to make more than one change at a time, when editing message filters,
Mozilla crashes, without even activating Full Circle.

Reproducible: Always
Steps to Reproduce:
1.Create a message filter "fubar"
2.Set it to move messages to folder fubar, when subject is "foo"
3.Click OK to exit back to the main Mail Task.
4.Return to edit the filter fubar.
5.Change the rule from filtering SUBJECT "foo" to TO OR CC "foo"
6.Add a new rule, that also filters to folder "fubar", with the rule of TO OR CC
"bar"
7.Click on OK

Actual Results:  When you make 2 or more such changes in the same edit session,
Mozilla crashes.

I and others have reported this bug before, but this most clearly shows the
steps to reproduce the problem.

Workaround is to limit editing to only one change at a time.

Comment 1

17 years ago
I believe you're hitting bug 90208. What theme/skin are you using?
I've hit it in a few ways, but usually when going directly from focus in a text
field to OK without hitting another field/focus in between. 
QA Contact: esther → laurel

Comment 2

17 years ago
changing assignee.
Assignee: mscott → sspitzer
(Reporter)

Comment 3

17 years ago
I have not changed from the default Modern Skin.
This does look like 90208, except that I am using modern skin.
Perhaps the 90208 thread represents more than one bug?

Comment 4

17 years ago
Well, I'm going to go ahead and mark it as duplicate. I'll put
you/bruce/reporter on the cc list there.  When that gets fixed I'll test more
extensively in both skins and we can double-check with you for status at that time.

*** This bug has been marked as a duplicate of 90208 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.