[B2G][Settings] No notification is given when trying to call a phone number within a contact with airplane mode enabled

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Dialer
VERIFIED WORKSFORME
4 years ago
4 years ago

People

(Reporter: KTucker, Assigned: kaze)

Tracking

({regression})

unspecified
1.2 C3(Oct25)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+, b2g18 unaffected, b2g-v1.2 affected)

Details

(Whiteboard: burirun2)

Attachments

(1 attachment)

Created attachment 813217 [details]
AirplaneContacts.txt

Description:
No notification is given when trying to call a phone number within a contact with airplane mode enabled.

Repro Steps:
1)  Updated Buri Build ID: 20131002004001
2)  Enable airplane mode.
3)  Tap on the "Contacts" icon.
4)  Tap on a contact that contains a phone number.
5)  Tap on the phone number.

Actual:
No notification is given to the user to disable Airplane mode.

Expected:
A notification is given to the user that they must disable Airplane mode to make a call.

Environmental Variables
Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20131002004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/b955a00f4167
Gaia: def8e152db6a317162c03a316f68c409f3af3979
Platform Version: 26.0a2
RIL Version: 01.02.00.019.056 

Notes:
Repro frequency: 100%
Test Suite Name: Airplane mode, Dialer
UCID: set-229
Link to failed test case: https://moztrap.mozilla.org/manage/case/2076/
See attached: logcat

Updated

4 years ago
Component: Gaia::System → Gaia::Dialer

Updated

4 years ago
blocking-b2g: --- → koi?

Updated

4 years ago
QA Contact: sparsons

Comment 1

4 years ago
This issue started to occur on the Buri 1.2 BuildID 20130912040201

Gaia   9ffd2899eb91388f7fc1ce6f7a895a6f5f922c05
SourceStamp a98569f21abe
BuildID 20130912040201
Version 26.0a1


Last working Buri 1.2 BuildID 20130911040201

Gaia   ebbb325958c66c3e68e1f190472d5f6e9076d83a
SourceStamp f9e8e8ce552c
BuildID 20130911040201
Version 26.0a1

This issue does not reproduce on the Leo 1.1 BuildID 20130917041200

Gaia   862b5761825e010e3cc5968c096377e1ea54bbf2
SourceStamp b459ac3ebe24
BuildID 20130917041200
Version 18.0
Keywords: regressionwindow-wanted
Regression needs to be fixed
blocking-b2g: koi? → koi+
Assignee: nobody → anthony
(Assignee)

Comment 3

4 years ago
looks similar to bug 92937, taking
Assignee: anthony → kaze
(Assignee)

Updated

4 years ago
Target Milestone: --- → 1.2 C3(Oct25)
(Assignee)

Comment 4

4 years ago
I cannot reproduce this bug with the latest master (875dbde) nor with the 1.2 branch (00d5964).

If I follow the STR I get a message saying that β€œTo make a call you need to disable airplane mode in settings.” β€” Sarah, can you confirm this bug still happens?
Flags: needinfo?(sparsons)
Looks like based on comment 4 a different bug might have already fixed this issue. Marking QA Wanted to confirm.
Keywords: qawanted

Comment 6

4 years ago
This issue is no longer reproduces on the Buri 1.2 aurora Build ID: 20131022004000

Gaia   00d5964eabf95a6a8a632420dfa36fc76dcbc9b7
SourceStamp 7453a764f9a9
BuildID 20131022004000
Version 26.0a2
Flags: needinfo?(sparsons)
Keywords: qawanted

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Verifying as Worksforme.  The user now sees the Airplane Mode notification when attempting to make a call from a contact with the Airplane Mode on.

Build ID: 20131025004000
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/5eabd267ef04
Gaia: 606517ceafe0950c2b89822d5f13353743334f2c
Platform Version: 26.0a2
RIL Version: 01.02.00.019.082
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.