All users were logged out of Bugzilla on October 13th, 2018

In Firefox' new (impoverished) Downloads window, the date of the download is too old

UNCONFIRMED
Unassigned

Status

()

UNCONFIRMED
5 years ago
8 months ago

People

(Reporter: nicolas.barbulesco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I have Firefox 23.0.1 Mac.

I have downloaded a file. I have the new Downloads window, which is now impoverished and which is now titled "Bibliothèque" ("Library"). In the list, I have one download. I had started the download several days ago, and the download finished several days ago. However, for an unknown reason, the date of the download in Firefox is "Hier" ("Yesterday").

The Info window of the file in the Finder says :
 - Created : before-before-yesterday 22:41
 - Modified : before-yesterday 02:12

It is wednesday 2 october 2013, 20:32.

The Finder is certainly correct, and Firefox is wrong.

I think this bug is a regression, compared to the "real" Downloads window of before.
Component: General → Downloads Panel
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20131015004002

Works fine for me on the latest Aurora - the displayed day in the Library is the same as the "modified" one in the Finder (same behavior is encountered also on Firefox 19 where the old Download Manager was used).

Nicolas, could you please verify if the issue is still reproducible if you use Firefox with a new profile? 
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(nicolas.barbulesco)
(Reporter)

Comment 2

5 years ago
I am sure that the bug occurred, but I have no idea why. So I cannot reproduce it.
Flags: needinfo?(nicolas.barbulesco)
Based on Comment 2 I'm setting the status of this bug to Resolved Worksforme. 

If anyone is still able to reproduce this issue and has more information to provide, please change the status back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

5 years ago
I encounter the bug again, in Firefox 25, in the new (crippled) Downloads window, named Library.

I have a download old from 1 week, and Firefox says Hier (Yesterday).

Maybe Firefox forgets that time passes when the Mac is asleep.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
So you 

* download a file
* notice that one day later it says (properly) "yesterday"
* put your PC at sleep
* resume x days later (but at least 24 hours)
* get still the (then improperly stated) "yesterday" for the item

?
Component: Downloads Panel → Bookmarks & History
Flags: needinfo?(nicolas.barbulesco)
(Reporter)

Comment 6

5 years ago
(In reply to XtC4UaLL [:xtc4uall] from comment #5)

> So you 
> 
> * download a file
> * notice that one day later it says (properly) "yesterday"
> * put your PC at sleep
> * resume x days later (but at least 24 hours)
> * get still the (then improperly stated) "yesterday" for the item
> 
> ?

It is about that, except that it is not a PC but a Mac.
Flags: needinfo?(nicolas.barbulesco)
(Reporter)

Comment 7

5 years ago
Indeed, Firefox think that time does not pass when the computer is asleep.

Now I encounter the bug in Firefox 25.0.1, on Mavericks, on a different Mac.

Yesterday monday, I downloaded a file at 20:38. The entry in the window said “20:38”. During the night, my Mac slept. Today tuesday the Mac is now awake, and the entry in Firefox’ window still says “20:38”. This is wrong. The entry must say “Yesterday at 20:38”. It is 22:25.
You don't know if this is a regression by any chance?
(Reporter)

Comment 9

5 years ago
Indeed, I think that this bug is a regression. I did not encounter these problems in the real Downloads window of before.
Component: Bookmarks & History → Downloads Panel
You need to log in before you can comment on or make changes to this bug.