Closed Bug 923424 Opened 7 years ago Closed 7 years ago

Test failure 'Recently Closed Tabs' sub menu has one entry - '0' should equal '1' in " /testSessionStore/testUndoTabFromContextMenu.js "

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P1)

defect

Tracking

(firefox28 unaffected, firefox29 fixed, firefox-esr24 unaffected)

RESOLVED FIXED
Tracking Status
firefox28 --- unaffected
firefox29 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: mario.garbi, Assigned: mario.garbi)

References

()

Details

(Keywords: intermittent-failure, regression, Whiteboard: [mozmill-test-failure])

Attachments

(2 files)

Happened on Mac OS X 10.6.8 (x86_64) with Firefox 27.0a1:

http://mozmill-daily.blargon7.com/#/functional/report/6ec6776efe900da3fd2b64a750d8e35a
Duplicate of this bug: 923423
Again on Mac OS X 10.6.8 (x86_64) with Firefox 27.0a2 en-US:
http://mozmill-daily.blargon7.com/#/functional/report/8a42e4b8f277f9c0268b061eb89d2472
I runned this for 100 times and Mario for 50, and it did't reproduced. We should check on an affected machine once it fails again.
Happened again on Mac OS X 10.6.8 (x86_64) with Firefox 27.0a2 fr:
http://mozmill-daily.blargon7.com/#/functional/report/ad464590da4913b3dafe381be12c6d0a
Failed again on Windows xp x86 with Nightly it:
http://mozmill-daily.blargon7.com/#/functional/report/ad464590da4913b3dafe381be136f8ae
OS: Mac OS X → All
Hardware: x86_64 → All
This is still failing.

http://mozmill-daily.blargon7.com/#/functional/report/2f1ca72938985fc4b989b7efcc460719
http://mozmill-daily.blargon7.com/#/functional/report/2f1ca72938985fc4b989b7efcc465c07

Mario, can you please look into this?
Assignee: nobody → mario.garbi
Status: NEW → ASSIGNED
I wasn't able to reproduce it yet, will keep an eye on future failures and investigate the CI machines when it fails again.
Didn't happen since 11/24, please reopen if needed.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
This just failed again on 27.0 Beta, de:
http://mozmill-release.blargon7.com/#/functional/report/94e33fe3d7ec0be6dbbfa0a702915e5c
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Duplicate of this bug: 962145
This has started to fail more often.

Updated the URL field since newer failures didn't show up anymore 6 failures today already:
http://mozmill-daily.blargon7.com/#/functional/failure?branch=All&platform=All&from=2014-01-22&test=%2FtestSessionStore%2FtestUndoTabFromContextMenu.js&func=testUndoTabFromContextMenu

We should try to figure this one out and fix it.
Tempted to raise priority to P1 if the failure rate maintains.
I can't reproduce this locally, but it has a failure rate on CI of roughly 90% right now.
We should skip now and find a fix.

Will have a skip patch shortly.
Priority: P2 → P1
Attached patch skip.patchSplinter Review
Skip patch due to recent failures until we can come with a fix.
Attachment #8363630 - Flags: review?(andrei.eftimie)
Attachment #8363630 - Flags: review?(andreea.matei)
Comment on attachment 8363630 [details] [diff] [review]
skip.patch

Review of attachment 8363630 [details] [diff] [review]:
-----------------------------------------------------------------

Disabled:
http://hg.mozilla.org/qa/mozmill-tests/rev/836c9cd29c99 (default)
Attachment #8363630 - Flags: review?(andrei.eftimie)
Attachment #8363630 - Flags: review?(andreea.matei)
Attachment #8363630 - Flags: review+
I tried to reproduce this locally on Ubuntu both with testruns and about 200 single test runs (mozmill -t) but wasn't able to reproduce. I took offline mm-ub-1310-32-3 and will try to reproduce it there in order to figure out what is going on.
Ran the test today about 600 times and only had 1 failure. I will continue testing tomorrow and hopefully find a way to reproduce it more constantly.
When I run those tests I can clearly see an error printed to the browser console and to the terminal:

console.error:
  Message: TypeError: docShell is null
  Stack:
    SessionHistoryInternal.collect@resource://app/modules/sessionstore/SessionHistory.jsm:48
this.SessionHistory<.collect@resource://app/modules/sessionstore/SessionHistory.jsm:28
SyncHandler.collectSessionHistory@chrome://browser/content/content-sessionStore.js:200
TabStateInternal._collectSyncUncached@resource://app/modules/sessionstore/TabState.jsm:329
TabStateInternal.collectSync@resource://app/modules/sessionstore/TabState.jsm:242
this.TabState<.collectSync@resource://app/modules/sessionstore/TabState.jsm:57
ssi_onTabClose@resource:///modules/sessionstore/SessionStore.jsm:1417
ssi_handleEvent@resource:///modules/sessionstore/SessionStore.jsm:765

This seems to be a regression in Firefox under specific circumstances and looks like bug 961861. I will ask over there.
Status: REOPENED → NEW
This problem should have been gone now with the backout of the patch from bug 961861. Mario, can you verify this? If that is the case let us unskip this test.
Attached patch unskip.patchSplinter Review
I have ran the single test 1000 times (2x500 runs) and we haven't had a single failure, uploading unskip patch so that we re-enable the test.
Attachment #8366540 - Flags: review?(hskupin)
Attachment #8366540 - Flags: review?(andrei.eftimie)
Attachment #8366540 - Flags: review?(andreea.matei)
Comment on attachment 8366540 [details] [diff] [review]
unskip.patch

Review of attachment 8366540 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, unskipped:
http://hg.mozilla.org/qa/mozmill-tests/rev/165c910926b5 (default)
Attachment #8366540 - Flags: review?(hskupin)
Attachment #8366540 - Flags: review?(andrei.eftimie)
Attachment #8366540 - Flags: review?(andreea.matei)
Attachment #8366540 - Flags: review+
Attachment #8366540 - Flags: checkin+
Status: NEW → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.