Closed Bug 923452 Opened 6 years ago Closed 6 years ago

[User Story] Single variant: Maximum length of SMS to convert to MMS customization by SIM

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.0, tracking-b2g:backlog, b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S2 (23may)
feature-b2g 2.0
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: sonmarce, Assigned: macajc)

References

Details

(Keywords: feature, Whiteboard: [ucid:System96, systemsfe][systemsfe])

User Story

As an Operator I want to set maximum length of SMS to be converted to MMS depending on the country, so that users will save money according to local mobile phone rates

Acceptance criteria:
* This is for the case a message does not fit in a single SMS and has to be splitted
* SMS length setting will be configured per each MCC/MNC after inserting a new SIM card for the first time
* There will be a default value for the case of no SMS length setting is configured for a MCC/MNC or no SIM card inserted
* Replacing or removing SIM card later on will imply no change in SMS length configuration
* After a factory reset, SMS length will be configured the same way as a brand new device

Attachments

(1 file, 1 obsolete file)

46 bytes, text/x-github-pull-request
borjasalguero
: review+
Details | Review
As an Operator I want to set maximum length of SMS to be converted to MMS depending on the country, so that users will save money according to local mobile phone rates

Acceptance criteria:
* This is for the case a message does not fit in a single SMS and has to be splitted
* SMS length setting will be configured per each MCC/MNC after inserting a new SIM card
* There will be default values for the case of no SMS length setting is configured for a MCC/MNC
Keywords: feature
Whiteboard: [systemsfe]
Priority: -- → P2
Whiteboard: [systemsfe] → [ucid:System96, systemsfe]
QA Contact: rafael.marquez
No longer blocks: 1.3-systems-fe
Updated following acceptance criteria:
* SMS length setting will be configured per each MCC/MNC after inserting a new SIM card for the first time
* There will be a default value for the case of no SMS length setting is configured for a MCC/MNC or no SIM card inserted
* Replacing or removing SIM card later on will imply no change in SMS length configuration
* After a factory reset, SMS length will be configured the same way as a brand new device

Also started to use the new User Story field
User Story: (updated)
Flags: in-moztrap?(rafael.marquez)
Assignee: nobody → cjc
Whiteboard: [ucid:System96, systemsfe] → [ucid:System96, systemsfe][systemsfe]
Target Milestone: --- → 1.4 S1 (14feb)
Target Milestone: 1.4 S1 (14feb) → 1.4 S2 (28feb)
blocking-b2g: --- → 1.4?
blocking-b2g: 1.4? → ---
No longer blocks: 1.4-systems-fe
Flags: in-moztrap?(rafael.marquez)
Target Milestone: 1.4 S2 (28feb) → 1.4 S3 (14mar)
moving to next sprint since this is not landing until after FC on 3/17
Target Milestone: 1.4 S3 (14mar) → 1.4 S4 (28mar)
Depends on: 978785
Target Milestone: 1.4 S4 (28mar) → 1.4 S5 (11apr)
Attached file Proposed patch v1 (obsolete) —
Attachment #8404787 - Flags: review?(borja.bugzilla)
Target Milestone: 1.4 S5 (11apr) → 1.4 S6 (25apr)
Comment on attachment 8404787 [details] [review]
Proposed patch v1

Some comments in Github! Please take a look and ask me again to review when ready!
Attachment #8404787 - Flags: review?(borja.bugzilla) → feedback+
Target Milestone: 1.4 S6 (25apr) → 2.0 S1 (9may)
Attachment #8404787 - Flags: review?(borja.bugzilla)
Attachment #8404787 - Flags: review?(borja.bugzilla) → review+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
sorry had to revert for test failures like https://tbpl.mozilla.org/php/getParsedLog.php?id=39191833&tree=B2g-Inbound
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached file patch v2
sms_test.js was missing the Settings mock, and that was causing the test to fail.
Borja, can you take a look? The only change between this and the patch you reviewed are in file sms_test.js
Thanks
Attachment #8404787 - Attachment is obsolete: true
Attachment #8419520 - Flags: review?(borja.bugzilla)
Also don't forget to put "r=borja" at the end of your commit log when you land. Thanks!
Component: Gaia::System → Gaia::SMS
You're right!!! I forgot, Thanks
Target Milestone: 2.0 S1 (9may) → 2.0 S2 (23may)
Comment on attachment 8419520 [details] [review]
patch v2

Great job! Thanks ;)
Attachment #8419520 - Flags: review?(borja.bugzilla) → review+
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
blocking-b2g: --- → backlog
feature-b2g: --- → 2.0
Flags: in-moztrap?(rafael.marquez)
All my tests executed in v2.0 with satisfactory results. I will send the test for import into moztrap
Status: RESOLVED → VERIFIED
Blocks: 1038825
Duplicate of this bug: 1038825
Blocks: 1039222
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.