[B2G][Streaming] User is unable to pause youtube video after lock screen has been enabled and disabled

RESOLVED FIXED in Firefox 26, Firefox OS v1.2

Status

()

Core
Audio/Video
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Jeni, Assigned: kats)

Tracking

({regression})

26 Branch
mozilla27
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:koi+, firefox25 unaffected, firefox26 fixed, firefox27 fixed, b2g18 unaffected, b2g-v1.2 fixed)

Details

(Whiteboard: burirun2, burirun3)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
If user is watching a youtube video and locks screen user is no longer able to pause video after unlocking screen.

Repro Steps:
1) Updated Buri to Build ID: 20131002004001
2) Open up Browser application
3) In URL type www.youtube.com and press enter
4) Tap on first video listed
5) Play video
6) While video is playing lock screen
7) Unlock screen
8) Pause Video
9) View what happens

Actual:
Video will not pause.  

Expected:
Video pauses

Environmental Variables
Device: Buri v 1.2 Moz RIL
Build ID: 20131002004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/b955a00f4167
Gaia: def8e152db6a317162c03a316f68c409f3af3979
Platform Version: 26.0a2
Firmware Version: 20130912

Repro frequency: (2/3, 100%, etc.)
Test Suite Name: Streaming
UCID: 6233
Link to failed test case: http://tinyurl.com/l8us32s
See attached url for issue: http://tinyurl.com/ksb58hv
(Reporter)

Comment 1

4 years ago
This does not repro on v1.1 Moz RIL

Device: Leo v 1.1 Mozilla
Build ID: 20131001041206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 02b975e6ce12922928c74276ac7d19432a03f126
Platform Version: 18.1
RIL Version: 01.01.00.019.235
status-b2g18: --- → unaffected
status-b2g-v1.2: --- → affected

Updated

4 years ago
blocking-b2g: --- → koi?
Component: Gaia → Video/Audio
Product: Boot2Gecko → Core
Version: unspecified → 26 Branch
I confirmed the symptom on v1.2 buri. It seems similar to Bug 919637. This bug's symptom is easier to reproduce.
It might be related to focus or event deliver handling.
kanru, do you have any thoughts about this bug?
Flags: needinfo?(kchen)

Updated

4 years ago
QA Contact: mdavydova

Comment 5

4 years ago
Regression range: 

Buri v1.2 Build ID: 20130730030200 – does not reproduce
Gecko: http://hg.mozilla.org/mozilla-central/rev/3d40d270c031
Gaia: ba5ff211fbf6a930326cc6a0d4a1205a7528630b
Platform Version: 25.0a1

Buri v1.2 Build ID: 20130731030205 - reproduces
Gecko: http://hg.mozilla.org/mozilla-central/rev/c2b375f3a909
Gaia: 9bfceaa90e8b92a379432b67121afa3cd3f14c90
Platform Version: 25.0a1
Keywords: regressionwindow-wanted

Updated

4 years ago
Assignee: nobody → sotaro.ikeda.g

Comment 6

4 years ago
Plus it since it is regression
blocking-b2g: koi? → koi+

Updated

4 years ago
Flags: needinfo?(kchen)
From Comment 5, I narrowed down the regression area to following. The problem happend by 'Merge m-c to inbound.'. It is a merge from birch.

----------------------------------------------------------

commit 313f74bcad2b13f2b4ea18d9abfce75b9f0e372d fail <********************************>
Author: Wes Kocher <wkocher@mozilla.com>
Date:   Tue Jul 30 15:31:10 2013 -0700

    Backed out changeset 675ea8aeb804 (bug 884897) for breaking builds on a CLOSED TREE


commit fd758076bd743b7b079b2e1aa0da9e70c80a01b1 fail <***************************************>
Merge: ab9f91f 3f36a5e
Author: Ryan VanderMeulen <ryanvm@gmail.com>
Date:   Tue Jul 30 18:08:18 2013 -0400

    Merge m-c to inbound.


commit ab9f91f38bc190c9645ccd38a862d7dde1264a8b   OK <*********************************>
Author: Olli Pettay <Olli.Pettay@helsinki.fi>
Date:   Wed Jul 31 01:04:38 2013 +0300

    Bug 899089 - Improve event listener reporting in CC graphs, r=khuey
> commit fd758076bd743b7b079b2e1aa0da9e70c80a01b1 fail
> <***************************************>
> Merge: ab9f91f 3f36a5e
> Author: Ryan VanderMeulen <ryanvm@gmail.com>
> Date:   Tue Jul 30 18:08:18 2013 -0400
> 
>     Merge m-c to inbound.
> 

following is related hg change. Some bugs' changed is mixed in this change. Touch related change is only Bug 866232.

http://hg.mozilla.org/mozilla-central/rev/0d8409268f42
I talked (off-line) to kats to investigate about the problem.
Assignee: sotaro.ikeda.g → bugmail.mozilla
Blocks: 928584
Created attachment 821964 [details] [diff] [review]
Patch
Attachment #821964 - Flags: review?(botond)

Updated

4 years ago
Attachment #821964 - Flags: review?(botond) → review+
https://hg.mozilla.org/integration/b2g-inbound/rev/48118186773b
https://hg.mozilla.org/mozilla-central/rev/48118186773b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
https://hg.mozilla.org/releases/mozilla-aurora/rev/027965e5fc5f
status-b2g-v1.2: affected → fixed
status-firefox25: --- → unaffected
status-firefox26: --- → fixed
status-firefox27: --- → fixed
Whiteboard: burirun2 → burirun2, burirun3

Updated

4 years ago
Duplicate of this bug: 919637
You need to log in before you can comment on or make changes to this bug.