It takes a long time to load the tinderbox build folder on inbound-archive.pub.build.mozilla.org with Ghostery 5.0.5 installed

RESOLVED FIXED

Status

()

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
I think it become unresponsive in the near future.
It will hit Bug 680767
Alice, I saw 1 to 2 second load times during development, and didn't see any see any perf issues. The bigger directories are about a megabyte of HTML though, so I'm interested in getting in more details from you.
(Reporter)

Comment 2

5 years ago
Now it is 5000+ folders/5 month.
And UI freezes while loading page(about 3-4 sec).

It is 10000+ folders/year.
I suppose that UI comes to freeze for approximately ten seconds.
Lets make this bug RelEng specific given that the underlying problem here is bug 680767 and would cause a duplicate. Would there be a way to handle that better on the new server?
Component: General → Other
OS: Windows 7 → All
Product: Core → Release Engineering
QA Contact: joduinn
Hardware: x86_64 → All
Summary: It takes a long time to listing folders → It takes a long time to load the tinderbox build folder on inbound-archive.pub.build.mozilla.org
Version: Trunk → unspecified
Actually I noticed the same thing until I used the profiler now to analyze where we spend the most time in. So in-fact it is working fine when Ghostery has been disabled. Alice, are you using this extension or another content blocking one?
(Reporter)

Comment 5

5 years ago
Adblock Plus+easylist maybe.
Anyway it is not affect for normal user. I think it is not so serious.
(In reply to Alice0775 White from comment #2)
> It is 10000+ folders/year.
> I suppose that UI comes to freeze for approximately ten seconds.

We're planning to keep 24 weeks of builds (4x 6 weeks), so the number of directories is bounded. We also have only half a cycle until we hit the peak size.

(In reply to Henrik Skupin (:whimboo) from comment #4)
> So in-fact it is working fine when Ghostery has been disabled.

I see this too - there's a delay after the initial page rendering until you can scroll/interact with it, which goes away if you disable Ghostery. Can't reproduce with Adblock Plus though.
(In reply to Nick Thomas [:nthomas] (Away Sep 26 - Oct 3) from comment #6)
> (In reply to Henrik Skupin (:whimboo) from comment #4)
> > So in-fact it is working fine when Ghostery has been disabled.
> 
> I see this too - there's a delay after the initial page rendering until you
> can scroll/interact with it, which goes away if you disable Ghostery. Can't
> reproduce with Adblock Plus though.

I will CC Felix, who is the dev for Ghostery. Would be good if we could get this fixed.
Did you hear anything back ?
Flags: needinfo?(hskupin)
No, but we could wait for a long time here if I don't actually CC Felix! :/ Sorry for that. Putting needinfo on him for feedback.
Flags: needinfo?(hskupin) → needinfo?(felix)

Comment 10

5 years ago
Hi all, thanks for adding me to this bug. I do see a lot of chatter that Ghostery generates on this page and I'm taking a closer look at this point.

Ghostery passes all remotely loaded elements through a matcher to determine if an element is a tracker. This includes images and this page has many images (folder icon). Ghostery should skip scanning or even selecting the images from the same domain, but this is applied inside the matcher, so on this page each image produced an emit event that added up to the biggest slow down according to profiling tool. I've fixed this and it sped up the page, but there are many other things I could do to speed up apparent loading times.  In any case, I'll release a beta today and update this ticket so you may confirm if I'm on the right track.

Thanks!
Flags: needinfo?(felix)
That is a ton better, Felix! I still get a short freeze but that seems to be Firefox specific and related to reflows. 

Thanks a lot for the quick fix! I think we should move this bug into extension compatibility.
Component: Other → Extension Compatibility
Product: Release Engineering → Firefox
QA Contact: joduinn
Summary: It takes a long time to load the tinderbox build folder on inbound-archive.pub.build.mozilla.org → It takes a long time to load the tinderbox build folder on inbound-archive.pub.build.mozilla.org with Ghostery 5.0.5 installed
Status: NEW → ASSIGNED
Fixed by new Ghostery version.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.