Wrong value in markup view

VERIFIED FIXED in Firefox 27

Status

()

Firefox
Developer Tools: Inspector
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Alice0775 White, Assigned: miker)

Tracking

({regression})

27 Branch
Firefox 27
x86_64
Windows 7
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox27+ verified)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Steps to Reproduce:
1. Open URL
2. Inspect Element
   --- observe value of attribute

Actual Results:
color code value displays instead of plain text.

<div id="#F00" class="#00F" title="#FFF"></div>

Expected Results:
Should not convert the value.
<div id="red" class="green" title="blue"></div>
(Reporter)

Comment 1

4 years ago
Regression window(fx-team)
Good:
http://hg.mozilla.org/integration/fx-team/rev/184a0076278b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130917075536
Bad:
http://hg.mozilla.org/integration/fx-team/rev/220ce292a894
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130917084033
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=184a0076278b&tochange=220ce292a894

Suspect:
e4e9ca3868d3	Michael Ratcliffe — Bug 911748 - Add default color dropdown to devtools options panel. r=jwalker
(Reporter)

Comment 2

4 years ago
err:

Actual Results:
<div id="#F00" class="#008000" title="#00F"></div>
I'll take this as we have decided not to translate color values in the markup view ... people expect to see the authored string.
Assignee: nobody → mratcliffe

Comment 4

4 years ago
Am I right in thinking the issue (inherit is replaced) in http://jsfiddle.net/YjPXm/2/ is this bug as well?

Link contents:
HTML: <div style="font-family: inherit;">Inspect This</div>
CSS: div { font-family: inherit; }
(In reply to Shaun from comment #4)
> Am I right in thinking the issue (inherit is replaced) in
> http://jsfiddle.net/YjPXm/2/ is this bug as well?
> 
> Link contents:
> HTML: <div style="font-family: inherit;">Inspect This</div>
> CSS: div { font-family: inherit; }

It is the same issue but needs addressing separately so I have logged bug 924136 for this.
Duplicate of this bug: 924346
Created attachment 814357 [details] [diff] [review]
wrong-value-in-markup-view-923884.patch

Very simple patch removes color conversions from markup-view.js and browser_inspector_markup_colorconversion.js as we no longer need it.

Now we always use colors as authored in the markup view.
Attachment #814357 - Flags: review?(jwalker)
Attachment #814357 - Flags: review?(jwalker) → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/153382a5ea88
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]

Updated

4 years ago
Duplicate of this bug: 924979
https://hg.mozilla.org/mozilla-central/rev/153382a5ea88
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27

Updated

4 years ago
Duplicate of this bug: 923883

Comment 12

4 years ago
I should submit this to Randy's million dollar challenge as proof of my ability to travel backwards in time, if only by half an hour.

Updated

4 years ago
status-firefox27: --- → fixed
tracking-firefox27: ? → +

Updated

4 years ago
Keywords: verifyme
verified with Nightly build 20131024030204
Status: RESOLVED → VERIFIED
status-firefox27: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.