Closed Bug 923996 Opened 9 years ago Closed 1 year ago

Intermittent test_playback_rate.html | application crashed [@ jemalloc_crash]

Categories

(Core :: Audio/Video: Playback, defect, P5)

x86
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: philor, Unassigned)

Details

(Keywords: crash, intermittent-failure, Whiteboard: [test disabled])

https://tbpl.mozilla.org/php/getParsedLog.php?id=28788360&tree=Fx-Team
Ubuntu VM 12.04 fx-team pgo test mochitest-1 on 2013-10-06 07:56:54 PDT for push 22a5355a3460
slave: tst-linux32-ec2-350

08:26:01     INFO -  153517 INFO TEST-PASS | /tests/content/media/test/test_playback_rate.html | Playback rate should be clamped to 5.
08:26:02     INFO -  INFO | runtests.py | exit 2816
08:26:02     INFO -  INFO | runtests.py | Application ran for: 0:26:02.750697
08:26:02     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpm5Lf53pidlog
08:26:02     INFO -  ==> process 2332 launched child process 2407
08:26:02     INFO -  ==> process 2332 launched child process 2421
08:26:02     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2407
08:26:02     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2421
08:26:02     INFO -  mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-team-linux-pgo/1381064449/firefox-27.0a1.en-US.linux-i686.crashreporter-symbols.zip
08:26:31  WARNING -  PROCESS-CRASH | /tests/content/media/test/test_playback_rate.html | application crashed [@ jemalloc_crash]
08:26:31     INFO -  Crash dump filename: /tmp/tmpNBGVNZ/minidumps/74a7f41a-1c3d-1db2-49853ca7-6aa1ffe7.dmp
08:26:31     INFO -  Operating system: Linux
08:26:31     INFO -                    0.0.0 Linux 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686
08:26:31     INFO -  CPU: x86
08:26:31     INFO -       GenuineIntel family 6 model 45 stepping 7
08:26:31     INFO -       1 CPU
08:26:31     INFO -  Crash reason:  SIGSEGV
08:26:31     INFO -  Crash address: 0x0
08:26:31     INFO -  Thread 31 (crashed)
08:26:31     INFO -   0  firefox!jemalloc_crash [jemalloc.c:22a5355a3460 : 1572 + 0x0]
08:26:31     INFO -      eip = 0x0805a6e7   esp = 0x8d4d5fc0   ebp = 0x8d4d5fc8   ebx = 0x0806b3d0
08:26:31     INFO -      esi = 0x8c643000   edi = 0xb7395040   eax = 0x0000007b   ecx = 0x8c600334
08:26:31     INFO -      edx = 0x00000324   efl = 0x00010286
08:26:31     INFO -      Found by: given as instruction pointer in context
08:26:31     INFO -   1  firefox!free [jemalloc.c:22a5355a3460 : 4638 + 0x4]
08:26:31     INFO -      eip = 0x0805fe6f   esp = 0x8d4d5fd0   ebp = 0x8d4d6028   ebx = 0x0806b3d0
08:26:31     INFO -      esi = 0x8c643000   edi = 0xb7395040
08:26:31     INFO -      Found by: call frame info
08:26:31     INFO -   2  libmozalloc.so!moz_free [mozalloc.cpp:22a5355a3460 : 48 + 0xa]
08:26:31     INFO -      eip = 0xb779cc7d   esp = 0x8d4d6030   ebp = 0x8d4d6048   ebx = 0xb779e7ac
08:26:31     INFO -      esi = 0x8c67a060   edi = 0x90df2060
08:26:31     INFO -      Found by: call frame info
08:26:31     INFO -   3  libxul.so!operator delete[](void*) [mozalloc.h:22a5355a3460 : 237 + 0xa]
08:26:31     INFO -      eip = 0xb3c26a79   esp = 0x8d4d6050   ebp = 0x8d4d6068   ebx = 0xb6e22fac
08:26:31     INFO -      esi = 0x8c67a060   edi = 0x90df2060
08:26:31     INFO -      Found by: call frame info
08:26:31     INFO -   4  libxul.so!soundtouch::FIFOSampleBuffer::ensureCapacity(unsigned int) [FIFOSampleBuffer.cpp:22a5355a3460 : 185 + 0xa]
08:26:31     INFO -      eip = 0xb50f1347   esp = 0x8d4d6070   ebp = 0x8d4d60a8   ebx = 0xb6e22fac
08:26:31     INFO -      esi = 0x8c67a060   edi = 0x90df2060
08:26:31     INFO -      Found by: call frame info
08:26:31     INFO -   5  libxul.so!soundtouch::FIFOSampleBuffer::ptrEnd(unsigned int) [FIFOSampleBuffer.cpp:22a5355a3460 : 142 + 0x11]
08:26:31     INFO -      eip = 0xb50f1398   esp = 0x8d4d60b0   ebp = 0x8d4d60c8   ebx = 0xb6e22fac
08:26:31     INFO -      esi = 0x928840cc   edi = 0x928840cc
08:26:31     INFO -      Found by: call frame info
08:26:31     INFO -   6  libxul.so!soundtouch::RateTransposer::downsample(float const*, unsigned int) [RateTransposer.cpp:22a5355a3460 : 270 + 0x19]
08:26:31     INFO -      eip = 0xb50f20ac   esp = 0x8d4d60d0   ebp = 0x8d4d6128   ebx = 0xb6e22fac
08:26:31     INFO -      esi = 0x00000383   edi = 0x928840cc
08:26:31     INFO -      Found by: call frame info
08:26:31     INFO -   7  libxul.so!soundtouch::RateTransposer::processSamples(float const*, unsigned int) [RateTransposer.cpp:22a5355a3460 : 304 + 0x4]
Test disabled in:
https://hg.mozilla.org/mozilla-central/rev/3dd1dc64123a
Whiteboard: [test disabled]
Component: Audio/Video → Audio/Video: Playback
P5
Priority: -- → P5

Hey Phill, it's been a long time since this issue was reported. However, it should be closed if it is no longer reproducible or updated with current affected versions. Could you please look into it? Thanks!

Flags: needinfo?(philringnalda)
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(philringnalda)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.