Closed Bug 924121 Opened 6 years ago Closed 6 years ago

crash in mozilla::ipc::MessageChannel::OnMaybeDequeueOne()

Categories

(Core :: IPC, defect, critical)

27 Branch
x86
All
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla27
Tracking Status
firefox27 + verified

People

(Reporter: tracy, Assigned: dvander)

References

Details

(Keywords: crash, regression, topcrash-win)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-00a2ecd0-3c18-44f6-8aca-536f62131006.
=============================================================

This crash began happening on 20130929030202 Nightly and has climbed up to #8 on crash list.

nothing of note in correlations or URLs
This may just be a changed signature of RPCChannel being renamed to MessageChannel, *but* we fixed the majority of that crash in bug 800347. Can you check for matching signatures before, and also provide a regression range if this is a new crash? There have been several IPC changes that landed recently, IIRC.
This signature is currently #4 on Nightly.

Investigating further, I don't think this morphed from bug 800347 - crash in mozilla::ipc::RPCChannel::OnMaybeDequeueOne. Tthe fix there and the first appearance of this signature don't match.

regression range (based on first appearance of this signature) - http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2f4397db1830&tochange=8f805d3ef377
Keywords: topcrash
Bug 901789 is the clear suspect. dvander can you take of investigating and possibly backing that patch out in the meantime?
Assignee: nobody → dvander
It appears that the new MessageChannel::~MessageChannel doesn't call Clear() at all, even though both AsyncChannel and RPCChannel used to.

I'm also a little confused about the patch http://hg.mozilla.org/mozilla-central/rev/9cc90a4b6475 because it looks like AsyncChannel.cpp still exists, but is not built.
Blocks: 901789
Keywords: regression
Yeah I'm not sure how that happened. I was very careful to include your changes in the final patch. Something must have gone wrong in between. Easy to fix though.
topcrash is being replaced by more precise keywords per https://bugzilla.mozilla.org/show_bug.cgi?id=927557#c3
Keywords: topcrashtopcrash-win
Attachment #816823 - Flags: review?(benjamin) → review+
This landed on m-c but for some reason wasn't marked correctly.

http://hg.mozilla.org/mozilla-central/rev/be0d4775e0ff
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
this signature no longer appears at all on the topcrash list for 27
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.