[B2G][Helix][Voicemail]There are voicemail notice when power up if there is a existed voicemal on simcard

RESOLVED WONTFIX

Status

P2
major
RESOLVED WONTFIX
5 years ago
6 months ago

People

(Reporter: lecky.wanglei, Assigned: alive)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

1.put in a simcard with one existed voicemail
2.power up device.
3.We can see voicemail notice on Firefox boot UI.


Actual results:

voicemail notice only display before the device entered OS, it would display the notice on boot logo.


Expected results:

voicemail notice only display when the device entered OS
(Reporter)

Updated

5 years ago
Priority: -- → P2
(Reporter)

Comment 1

5 years ago
Hi Wayne:
 We do not know whether this is a case caused by gaia, could you help us to dispatch it to the correct person(maybe Gecko or Gaia)
Flags: needinfo?(wchang)
(Reporter)

Comment 2

5 years ago
gaia:8059864bd278645ab5d2598b5ed595154136c253
gecko:0265cd51b4dc64ca100353482ada2025df6f5f53
gonk-misc:ca9192d7ef6037016d4723647d86b72f7a410633
This is not in SMS. Moving components and flagging :alive who will probably know more.
Component: Gaia::SMS → Gaia::System
Flags: needinfo?(alive)
This is talking about lazy load or show notifications after init logo disappears. A bug indeed but it depends on the solutions we choose.

Any member on system FE/system BE team would like to work on this please steal.
Assignee: nobody → alive
Flags: needinfo?(alive)
(Reporter)

Comment 5

5 years ago
Hi Alive 
  What's the reason that you doubt? And will this bug would be fixec on V1.1HD? Thank you very much!
Flags: needinfo?(wchang) → needinfo?(alive)
(In reply to lecky from comment #5)
> Hi Alive 
>   What's the reason that you doubt? And will this bug would be fixec on
> V1.1HD? Thank you very much!

I don't know we have v1.1hd still. This couldn't go to that if it's not blocking I think. Not sure.
Flags: needinfo?(alive)
The right solutions looks to me is lazy load the voicemail + notifications after device is booted.(lockscreen is shown?)
I think android does the same thing.
But currently system app may not be ready for that yet.

Setting to modularization meta.
Blocks: 912952
(Reporter)

Comment 8

5 years ago
hi
(Reporter)

Comment 9

5 years ago
hi beatriz:
Could you accept this issue not solved on V1.1HD? Thank you very much!
Flags: needinfo?(brg)
(Reporter)

Updated

5 years ago
Severity: normal → major
After discussing it with Wayne and Alive, its not a regression, same on all 1.0.1 and 1.1.
We are not landing new functionalities in v1.1 branches.
Flags: needinfo?(brg)
Blocks: 971442
No longer blocks: 971442

Comment 11

6 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.