Closed Bug 924624 Opened 6 years ago Closed 6 years ago

[User Story] Add edge gestures to FTE tutorial

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.0, tracking-b2g:backlog, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S1 (14feb)
feature-b2g 2.0
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: pdol, Assigned: sjochimek)

References

Details

(Keywords: feature, Whiteboard: [ucid:System92, ft:systems-fe, 2.0][systemsfe][p=13])

Attachments

(3 files, 1 obsolete file)

1.51 MB, application/pdf
Details
12.99 KB, application/zip
Details
46 bytes, text/x-github-pull-request
Details | Review
User Story:

As a user, I want a tutorial to inform me how to use edge gestures to switch between open apps so that the ability is more discoverable.


Acceptance Criteria:

1. The FTE tutorial contains a page which visually informs the user how to switch between open app using edge gestures.
Attached file Tutorialv0.1.pdf
Wireframes for the new view attached.
Blocks: 939174
Note that we need the ability to disable this if a decision is made not to ship the app-to-app switching feature in 1.3.
Whiteboard: [ucid:System92][systemsfe] → [ucid:System92, 1.3:P2, ft:systems-fe]
Whiteboard: [ucid:System92, 1.3:P2, ft:systems-fe] → [ucid:System92, 1.3:P2, ft:systems-fe][systemsfe]
Target Milestone: --- → 1.3 Sprint 5 - 11/22
Assignee: nobody → sjochimek
Flags: in-moztrap?(jhammink)
No longer blocks: 1.3-systems-fe
Whiteboard: [ucid:System92, 1.3:P2, ft:systems-fe][systemsfe] → [ucid:System92, 1.4:P2, ft:systems-fe][systemsfe]
Attached file Github PR (obsolete) —
Still missed the assets but the logic is here.
Francis, can you provide the missing screen ?
Flags: needinfo?(fdjabri)
Flags: in-moztrap?(jhammink)
Flagging Peter La to provide visual design assets. The spec is complete.
Flags: needinfo?(fdjabri) → needinfo?(pla)
Hi Sam, I've attached the screen for app swiping.  Sorry for the delay, thanks!
Flags: needinfo?(pla) → needinfo?(sjochimek)
Comment on attachment 8343671 [details] [review]
Github PR

Thanks Eric.
Etienne can you review this please?
Attachment #8343671 - Flags: review?(etienne)
Flags: needinfo?(sjochimek)
Comment on attachment 8343671 [details] [review]
Github PR

Awesome, this feels so official :)

There's some unit test work left to do (yes the ftu app has unit tests :)), and :arcturus should probably to the next review round since I'm not a ftu peer.

But *really* happy to see this :)
Attachment #8343671 - Flags: review?(etienne)
Comment on attachment 8343671 [details] [review]
Github PR

Updated the patch. The tests are green.
Attachment #8343671 - Flags: review?(etienne)
Attachment #8343671 - Flags: review?(etienne) → review?(francisco.jordano)
Comment on attachment 8343671 [details] [review]
Github PR

Left some comments on github, just to understand a bit better the PR.

Also asked for a bit more of flexibility to set up the edge gesture tutorial screen not always on the last step of the tutorial.

Once that is done, please ask for the review again, will be happy to r+.

Also asking Borja for feedback, since I know there is a huge patch for Firefox Accounts about to land and would like to know how it will impact the refactor of the navigation progress.

Thanks for the work!
Attachment #8343671 - Flags: review?(francisco.jordano) → feedback?(borja.bugzilla)
Comment on attachment 8343671 [details] [review]
Github PR

I have updated the pr, thanks.
Attachment #8343671 - Flags: review?(francisco.jordano)
Comment on attachment 8343671 [details] [review]
Github PR

Thanks Sam!
Attachment #8343671 - Flags: review?(francisco.jordano) → review+
merged: https://github.com/mozilla-b2g/gaia/commit/0602aa7814a65448c17c2119d026da66df19490b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Depends on: 967612
Reverted for causing perma-fail in the Gaia unit tests on TBPL.
https://github.com/mozilla-b2g/gaia/commit/ac94739a01d64e86890f54f1795ff8e82b8e7939

https://tbpl.mozilla.org/php/getParsedLog.php?id=34068371&tree=B2g-Inbound
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 1.3 Sprint 5 - 11/22 → ---
Target Milestone: --- → 1.4 S1 (14feb)
Attached file Github PR
I have corrected the patch.
Thanks to Julien, i could reproduce the failure locally and fix it.
The changes are minimal. So i merge that pr, as i already have an r+ and all failures are gone from travis https://travis-ci.org/mozilla-b2g/gaia/builds/18331359

Merged on master: https://github.com/mozilla-b2g/gaia/commit/63fbca51e28c58752f533842f8181d3a5819a008
Attachment #8343671 - Attachment is obsolete: true
Attachment #8343671 - Flags: feedback?(borja.bugzilla)
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Flags: in-moztrap?(jhammink)
Whiteboard: [ucid:System92, 1.4:P2, ft:systems-fe][systemsfe] → [ucid:System92, 1.4:P2, ft:systems-fe][systemsfe][p=13]
Flags: in-moztrap?(jhammink)
Whiteboard: [ucid:System92, 1.4:P2, ft:systems-fe][systemsfe][p=13] → [ucid:System92, ft:systems-fe, 2.0][systemsfe][p=13]
blocking-b2g: --- → backlog
No longer depends on: edge-gestures
feature-b2g: --- → 2.0
Mass modify - set status-b2g-v2.0 fixed for fixed bugs under vertical homescreen dependency tree.
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.