Closed Bug 924903 Opened 7 years ago Closed 7 years ago

[Contacts] Custom tag for mobile, email an address can be edited but it is not saved

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

VERIFIED FIXED
1.2 C2(Oct11)
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: isabelrios, Assigned: gtorodelvalle)

References

Details

(Keywords: regression, Whiteboard: [u=commsapps-user c=contacts p=0])

Attachments

(2 files)

Checked with v1.2 latest build (10/09):
Gecko-bd1bd24
Gaia-1499c58

STR
1. Create a mew contact (or edit an existing one)
2. Tap on Mobile, to change the mobile type assigned
3. Tap on Custom field and write something
4. Tap on Done

EXPECTED
It is possible to add a custom tag for mobile, email or address information.

ACTUAL
Although it is possible to tap on Custom field and write a different tag, when tapping on Done, the change is dismissed.
Assignee: nobody → gtorodelvalle
Summary: [Contacts] Custom tag for mobile, mail an email can be edited but it is not saved → [Contacts] Custom tag for mobile, email an address can be edited but it is not saved
Attached file 12769.html
Attachment #815314 - Flags: review?(jmcf)
Comment on attachment 815314 [details]
12769.html

good work German,

thanks!
Attachment #815314 - Flags: review?(jmcf) → review+
https://github.com/mozilla-b2g/gaia/commit/a2932738a6c05382e0f17284a3d24542439c9afe
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.2 C2(Oct11)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached file 12787.html
Sorry guys! Really freaked out how that end up landing in master taking into consideration all the linting controls in the middle... I recall some rebasing and probably that was the cause. Well that was the cause but mainly myself precipitating about the merging, of course. 

This (and upcoming) times I'll make sure that Travis talks before landing. Sorry again!
Attachment #815751 - Flags: review?
Attachment #815751 - Flags: review? → review+
https://github.com/mozilla-b2g/gaia/commit/8538dac23e3d3416025824f3f27b3f99c37c40fe
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
triage: koi+ regression
blocking-b2g: koi? → koi+
I was not able to uplift this bug to v1.2.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.2, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.2
  git cherry-pick -x -m1 8538dac23e3d3416025824f3f27b3f99c37c40fe
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(gtorodelvalle)
Hi John, you were completely right. There is a dependency we forgot to include in the bug. The point is that we are still trying to get Ayman's confirmation about the bug 925307 's patch. As soon as I get his confirmation I will ask for the v1.2 approval and once granted cherry picking bug 925307 's patch before this one will work just fine. I just verified it ;-)

Thank you very much.
Depends on: 925307
Flags: needinfo?(gtorodelvalle)
Since bug 925307 has just been uplifted to v1.2, everything should go fine now... John, would you be so kind to give it a new try to the cherry picking? If you prefer me to do it, just need-info me, please. Thanks!
Flags: needinfo?(jhford)
Uplifted 8538dac23e3d3416025824f3f27b3f99c37c40fe to:
v1.2: 819087cd3bb2de9c2afdbfca15496ea02968f9f4
Flags: needinfo?(jhford)
Verified v1.2 11/06 build:

Gecko-e612f4f
Gaia-b12d548
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.