Appcached web apps not being cached on at least Firefox for Android

RESOLVED WONTFIX

Status

()

P2
normal
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: Pwnna, Unassigned)

Tracking

Trunk
All
Android
Points:
---

Firefox Tracking Flags

(firefox25 affected, firefox26 affected, firefox27 affected, firefox28 affected, fennec+)

Details

(Whiteboard: [WebRuntime])

(Reporter)

Description

5 years ago
Webapps that are installed (either via the marketplace or the install button) to device that has an appcache_path entry does not actually get cached on at least Firefox for Android (I have nightly)..

You can try this yourself: go to either http://nextotrain.com or http://bus.shuhaowu.com and see the site get appcached.

You can try installing these apps from the marketplace by searching for either "Next Otrain" or "Sudbury Bus Tracker". For the latter you can install directly from the menu on the website.

Turn off your network and watch the apps fail to load.

I think this is a pretty big issue, considering that if Mozilla were to push for Open web apps, being able to cache most of the app offline is a huge deal.

Updated

5 years ago
Component: Webapp Runtime → Web Apps
Product: Firefox → Firefox for Android
QA Contact: aaron.train
Version: unspecified → Trunk

Updated

5 years ago
tracking-fennec: --- → ?
Did this ever work? If so, we need a regression range.

Myk - Can you assign as appropriate?
Assignee: nobody → myk
tracking-fennec: ? → +
Keywords: regressionwindow-wanted
I'm not sure if this ever worked.

James, Martyn: can you confirm?

Updated

5 years ago
status-firefox25: --- → unaffected
status-firefox26: --- → affected
status-firefox27: --- → affected
status-firefox28: --- → affected

Comment 3

5 years ago
I can not reproduce the bug on any branch. Device used is Asus Transformer Tab (Android 4.0.4).
The only difference is that on firefox 25 a doorhanger is displayed asking to store data on your device for offline use.
(Reporter)

Comment 4

5 years ago
Wait. On an installed app? Or just the site. The site should work fine. If yoou install it .. that's a different story.

Comment 5

5 years ago
I was tested on this website http://nextotrain.com, not the web app.
(Reporter)

Comment 6

5 years ago
The website should be working fine. Installing it as a web app (get it from the firefox marketplace) will not work.

Comment 7

5 years ago
Good build: 05.09.2013;
Bad build: 05.10.2013;
Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ea059733677c&tochange=08be63954b6b
Tested on Asus Transformer Pad (Android 4.0.3)
Keywords: regressionwindow-wanted
This broke in the Firefox 23 development cycle.
status-firefox25: unaffected → affected
I can't reproduce this regression range using the following steps

1. Install the Next oTrain app
2. Launch Next oTrain
3. Verify function of the app (accept storage dialog if it appears)
4. Kill Firefox (and thus the app)
5. Launch the app from about:apps

Flaviu would you provide the steps you are using to reproduce this issue.
Flags: needinfo?(flaviu.cos)
OS: Linux → Android
Hardware: x86_64 → All
(Reporter)

Comment 10

5 years ago
The steps to reproduce should be the following: 

1. Install the Next OTrain app
2. Launch the next otrain app to verify it works
3. Kill your internet connection by disconnecting from 3G and wifi
4. Kill Firefox/App
5. Relaunch the app and verify it works.
That fails to work on Firefox 22 which should be unaffected according to the regression range from comment 7.
(Reporter)

Comment 12

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #1)
> Did this ever work?

I would like to pose this question again.

Comment 13

5 years ago
(In reply to Shuhao Wu [:Pwnna] from comment #12)
> Did this ever work?
In order to find the regression range I tested the following nightly builds:
01.01.2013 build - Not reproducible
05.01.2013 build - Not reproducible
05.07.2013 build - Not reproducible
05.09.2013 build - Not reproducible
05.10.2013 build - Reproducible
05.15.2013 build - Reproducible
06.01.2013 build - Reproducible
07.01.2013 build - Reproducible
Flags: needinfo?(flaviu.cos)
The May 9 nightly was built from revision ea059733677c (gecko-dev: 831aab1) according to <https://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2013/05/2013-05-09-03-10-47-mozilla-central-android/fennec-23.0a1.multi.android-arm.txt>.

The May 10 nightly was built from revision 2673016e7df4 (gecko-dev: e9058c7) according to <https://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2013/05/2013-05-10-09-41-37-mozilla-central-android/fennec-23.0a1.multi.android-arm.txt>.

So I built builds from those revisions. But they both exhibit the same behavior for me when I follow the steps in comment 10: the runtime displays a "server not found" error dialog, even though adb logcat reports "offline cache update done."
Strangely, the nightly builds themselves both work in my tests, even though they're built from the same revisions as my custom builds (of course there are build system and configuration differences; in particular, I'm building debug builds).


Flaviu, can you confirm which builds you tested?  I tested the following builds from May 9 and 10:

May 9: https://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2013/05/2013-05-09-03-10-47-mozilla-central-android/fennec-23.0a1.multi.android-arm.apk

May 10: https://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2013/05/2013-05-10-09-41-37-mozilla-central-android/fennec-23.0a1.multi.android-arm.apk


And I tested with both the "Next Otrain" and "Wikipedia" apps (the latter is easier to test because it appears on the Marketplace home page).
Erm, correction: the two nightly builds both fail to restore Next Otrain from cache in the absence of network; and they both succeed in restoring Wikipedia from cache in the same situation.  So I can't reproduce the problem across that regression range, but I do see the problem with Next Otrain on both builds.
Assignee: myk → nobody
Whiteboard: [WebRuntime]

Comment 17

5 years ago
What I actually see nowadays is that once we have loaded the appcache resources for an installed app we never update them even if the manifest changes, which means any updates to a hosted app with appcache do never arrive on Android installations. :(
Priority: -- → P2
Per bug 1235869, we're going to disable the Android web runtime, so we won't fix this bug in it.

(This is part of a bulk resolution of bugs in the Firefox for Android::Web Apps component, from which I attempted to exclude bugs that are not specific to the runtime, but it's possible that I included one accidentally.  If so, I'm sorry, and please reopen the bug!)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.