Closed Bug 925199 Opened 6 years ago Closed 6 years ago

Move touch-events.js to /toolkit/

Categories

(DevTools :: WebIDE, defect, P1)

x86
All
defect

Tracking

(firefox26 fixed, firefox27 fixed)

RESOLVED FIXED
Firefox 27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed

People

(Reporter: paul, Assigned: paul)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

No description provided.
Attached patch Patch V1Splinter Review
Attachment #815211 - Flags: review?(poirot.alex)
Code of touch-events.js has changed.
Component: Developer Tools: Responsive Mode → Developer Tools: App Manager
Priority: -- → P1
Whiteboard: [needed-in-aurora-26][waiting-for-review]
Alex, can you also make sure that the simulator uses this file?
Blocks: 920742
Comment on attachment 815211 [details] [diff] [review]
Patch V1

Review of attachment 815211 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/devtools/Loader.jsm
@@ +59,5 @@
>          "devtools/toolkit/webconsole": "resource://gre/modules/devtools/toolkit/webconsole",
>          "devtools/app-actor-front": "resource://gre/modules/devtools/app-actor-front.js",
>          "devtools/styleinspector/css-logic": "resource://gre/modules/devtools/styleinspector/css-logic",
>          "devtools/css-color": "resource://gre/modules/devtools/css-color",
> +        "devtools/touch-events": "resource://gre/modules/devtools/touch-events",

Why don't we add a toolkit mapping (or something) and stop doing specifics for each new module we want to access from devtools/toolkit.
This really doesn't scale. Is there anything planned for the merge of browser/devtools and toolkit/devtools regarding loader require paths?
To make it work on the simulator, we just need to update gaia, see bug 925289.
(In reply to Alexandre Poirot (:ochameau) from comment #4)
> Why don't we add a toolkit mapping (or something) and stop doing specifics
> for each new module we want to access from devtools/toolkit.
> This really doesn't scale. Is there anything planned for the merge of
> browser/devtools and toolkit/devtools regarding loader require paths?

I agree, it is definitely getting crazy...  Plus, people tend to forget to update the SrcdirProvider each time they add a new custom entry too.

I feel like people might be waiting for devtools to move to top-level, but perhaps there is something we can do to improve this in the short term.  Seems reasonable enough to just define "devtools/toolkit", remove all the other toolkit entries, and then go update the calls.
I agree with both of you. Can we do that in a follow-up? This patch is ready and is important.
Follow-up: bug 925692
Comment on attachment 815211 [details] [diff] [review]
Patch V1

Review of attachment 815211 [details] [diff] [review]:
-----------------------------------------------------------------

We can clean up the other requires in followups, I even encourage to do that.
But it would be great to have the final require path (implemented in a sane way) for this module,
so that we can land a fix in gaia only once.
Attachment #815211 - Flags: review?(poirot.alex) → review+
Keywords: checkin-needed
Whiteboard: [needed-in-aurora-26][waiting-for-review] → [needed-in-aurora-26]
https://hg.mozilla.org/integration/fx-team/rev/5836dc9eaa65
Keywords: checkin-needed
Whiteboard: [needed-in-aurora-26] → [needed-in-aurora-26][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/5836dc9eaa65
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [needed-in-aurora-26][fixed-in-fx-team] → [needed-in-aurora-26]
Target Milestone: --- → Firefox 27
Comment on attachment 815211 [details] [diff] [review]
Patch V1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (touch events simulation)
User impact if declined: can't use touch events with non-Firefox builds (B2G desktop for example)
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low (moving a file)
String or IDL/UUID changes made by this patch: none
Attachment #815211 - Flags: approval-mozilla-aurora?
Whiteboard: [needed-in-aurora-26] → [waiting-for-aurora-approval]
Attachment #815211 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [waiting-for-aurora-approval] → [land-in-aurora-26]
Depends on: 927266
Blocks: 891882
Whiteboard: [qa-]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.