Status

RESOLVED DUPLICATE of bug 90337
18 years ago
10 years ago

People

(Reporter: pbergsag, Assigned: hewitt)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.2+) Gecko/20010726
BuildID:    2001072615

(I am not sure what browser componet this belongs in hence I put it in
"Browser-General")

After browsing to several web adresses the browser adreess bar fails to respond
to any  new address new adress entered into the web address bar at the top of
the page. The browser itself did not crash or freeze, just the ability to surf
to a new web address has been lost. I can quit Mozilla and restart and the
browser will function again as it normally would.

Reproducible: Sometimes
Steps to Reproduce:
1.Surf to several web sites.
2.Sometimes but not always the browser fails to load the next web address and
appears frozen.


Actual Results:  After surfing to several web adresses the web address bar at
the top of the page fails and will not load a new address.

Expected Results:  The browser should load all the web address I enter into the
adress bar at the top of the page without failing or freezing.

The program itsel was not forzen or crashed. The web address bar was the only
function that stopped working. I did not links on the web page so I don't know
if they also stopped functioning.

(**This may be a duplicate bug since I did not know which componet of Mozilla to
search for the bug. I'll risk this since I feel this bug is important, and since
it occurs at random may miss being reported. I am sorry if it is a duplicate bug
report.)
Reporter: 
Can you use links on pages/bookmarks and only the URL Bar fails ?
(Reporter)

Comment 2

18 years ago
I know that the bookmarks failed. I could enter a new web address into the
address bar manually by typing or cut and paste, but it failed to work. When I
clicked on a bookmark it failed and its address did not replace the one already
in the address bar. I did not test page links so I am not sure if they would
fail as well. This bug has occured on previous builds, but since it only occurs
at random I have been unable to test it very much. Another way of discribing
this bug is: "After running the browser for a while urls all begin to fail". I
believe this applies to page links but I have yet to fully confirm this. 

I hope this additional information helps. This is not an easy bug to test since
I never know when or why it will occur. One thing I do know is that this bug
will occur and the only remedy is to restart the browser. One thought is that
this bug may be more likely to occur the longer the browser is used or the
amount of ram used (ie how large Mozilla's footprint is). I know the browser's
stability decreases the longer it is used.
trying networking:http...
Assignee: asa → neeti
Component: Browser-General → Networking: HTTP
QA Contact: doronr → benc

Comment 4

18 years ago
WFM on MacOS 8.6 with build id: 2001072711, after 2 navigation sessions with to
different mozilla processes i couldn't reproduce the bug opened more than 20 url.

Comment 5

18 years ago
I confirm that this occurs. Reporter, you'll find that you don't need to quit Mozilla to 
restore URL bar keyboard focus. Simply switch to another application, then back to 
Mozilla. You'll find you can use the URL bar again.

In fact, I think you don't even need to switch out of Mozilla, just spawn a new window, 
close it, and then the old window should be usable again.

I'd be surprised if this isn't a dup, but a cursory search yields nothing ("url bar key focus 
lost" was my search phrase). There are literally hundreds of bugs about keyboard focus 
problems.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

18 years ago
*** Bug 93446 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Doesn't look like networking -> URL bar. 
Assignee: neeti → alecf
Component: Networking: HTTP → URL Bar
QA Contact: benc → claudius

Comment 8

17 years ago
dupe of bug 82534. there are others but this is the first open one i
found.(searched 'type url')

*** This bug has been marked as a duplicate of 82534 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
claudius@netscape.com: I wrote an email to you but i get an unkown-user error 
message...

Hi ! 

You duped this bug 
I asked the reporter in this bug (I know that there is a bug about the URL Bar): 
Can you use links on pages/bookmarks and only the URL Bar fails ? 

Answer: I know that the bookmarks failed. 

bug 82534 is that you can't type in the URL bar, you can't get a caret. 

Comment 11

17 years ago
     I don't understand why these are dupes! 92531 is about being ABLE to 
type the address in and mozilla not loading the page. 82534 is about NOT 
being able to type the address in at all.

The expected results for 82534 are:
Typing (should) appear(s)

The expected results for 92531 are:
The browser should load all the web address I ENTER (emphasis mine) 
into the adress bar at the top of the page without failing or freezing.

You should "un-dupe" 92531, as it is not about typing but about loading.

Comment 12

17 years ago
I stand corrected. no need for emails. If you want to comment on a bug
simply comment in the bug. I don't fear being called out for incorrect actions.
Reopening.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 13

17 years ago
reassign url bar bugs to new owner..
Assignee: alecf → blakeross
Status: REOPENED → NEW

Comment 14

17 years ago
Joe was dying to have these bugs. Who am I to say no?
Assignee: blakeross → hewitt
(Assignee)

Comment 15

17 years ago
works for me... I used to see this happen on occasion but have not in quite a
long time.  Without any steps to reproduce, not much I can do with this bug.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 16

17 years ago
I can reliably reproduce this bug under Mac OS X (10.1.2) with 0.9.6 and 0.9.7.

1. Using Mail, press "Get Msgs" to download all messages. Press again, when
there are none. The "loading" box will not stop. (This is also a bug.)
2. Open a Navigator window.
3. Enter a URL. You can type, but pressing enter does nothing.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 17

17 years ago

*** This bug has been marked as a duplicate of 90337 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.