Closed Bug 925375 Opened 7 years ago Closed 7 years ago

b2g desktop mochitests should use b2g-bin if it exists

Categories

(Release Engineering :: General, defect)

All
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: ahal, Assigned: ahal)

References

Details

Attachments

(1 file)

This didn't end up being the cause of bug 921180, but I think we want to land this anyway.. right jgriffin?
Attachment #815417 - Flags: review?(jgriffin)
Blocks: 916127
Comment on attachment 815417 [details] [diff] [review]
Patch 1.0 - use b2g-bin if it exists

Review of attachment 815417 [details] [diff] [review]:
-----------------------------------------------------------------

::: scripts/b2g_desktop_unittest.py
@@ +140,5 @@
> +        # if the b2g-bin binary exists, use it
> +        if not self.binary_path.endswith('-bin'):
> +            self.binary_path = '%s-bin' % self.binary_path
> +        if not os.path.isfile(self.binary_path):
> +            self.binary_path = self.binary_path[:-len('-bin')]

Wouldn't this be a little cleaner like:

bin_path =  '%s-bin' % self.binary_path
if (os.path.isfile(bin_path):
   self.binary_path = bin_path
Attachment #815417 - Flags: review?(jgriffin) → review+
(In reply to Jonathan Griffin (:jgriffin) from comment #1)
> Wouldn't this be a little cleaner like:
> 
> bin_path =  '%s-bin' % self.binary_path
> if (os.path.isfile(bin_path):
>    self.binary_path = bin_path

Sure, if we can count on mozharness always returning the non-bin version. I guess that is a fair assumption to make though.
You're probably right; we shouldn't assume what mozharness will pass to us, since that could change in the future.
Because of the patch in bug 921180, I think this is no longer necessary. No point in having the check in two separate places, and if it's something we always want to do, then I think it belongs in the harness anyway.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.