Closed Bug 925412 Opened 8 years ago Closed 8 years ago

Add TeliaSonera Root CA v1 root certificate to NSS

Categories

(NSS :: CA Certificates Code, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kwilson, Unassigned)

References

Details

Attachments

(1 file)

This bug requests inclusion in the NSS root certificate store of the following certificate, owned by TeliaSonera

Friendly name: TeliaSonera Root CA v1
Certificate location: http://repository.trust.teliasonera.com/teliasonerarootcav1.cer
SHA1 Fingerprint: 43:13:BB:96:F1:D5:86:9B:C1:4E:6A:92:F6:CF:F6:34:69:87:82:37
Trust flags: Websites, Email

This CA has been assessed in accordance with the Mozilla project guidelines, and the certificates approved for inclusion in bug #539924.

The next steps are as follows:

1) A representative of the CA must confirm that all the data in this bug is correct, and that the correct certificate has been attached.

2) A Mozilla representative creates a patch with the new certificate, and provides a special test version of Firefox.

3) A representative of the CA uses the test version of Firefox to confirm (by adding a comment in this bug) that the certificate has been correctly imported and trust bits correctly set.

4) The Mozilla representative requests that another Mozilla representative review the patch.

5) The Mozilla representative adds (commits) the patch to NSS, then closes this bug as RESOLVED FIXED.

6) At some time after that, various Mozilla products will move to using a version of NSS which contains the certificate. This process is mostly under the control of the release drivers for those products.
Pekka, Please see step #1 above.
(In reply to Kathleen Wilson from comment #1)
> Pekka, Please see step #1 above.

I confirm that the data in this bug is correct, and that the correct certificate has been attached.
Thanks for confirming that the data in this bug is correct.

Root inclusions and changes are usually grouped and done as a batch when there is
either a large enough set of changes or about every 3 months.

At some point in the next 3 months a test build will be provided and this bug
will be updated to request that you test it. Since you are cc'd on this bug,
you will get notification via email when that happens.
Depends on: 957300
Please test that your root has been correctly included, that the trust bits are set correctly, and that connections to your test site work with basic domain validation status.

The test build is available at
  http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kaie@kuix.de-e9ed86288188/

Download a binary for your preferred operating system, you probably want one of the following files:
  try-linux/firefox-....en-US.linux-i686.tar.bz2
  try-linux64/firefox-....en-US.linux-x86_64.tar.bz2
  try-macosx64/firefox-....en-US.mac.dmg
  try-win32/firefox-....en-US.win32.zip

Please follow the test instructions here:
https://wiki.mozilla.org/CA:How_to_apply#Testing_Inclusion

Make sure you use a fresh profile for your testing.
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
I've tested the new build with provided browser in Windows 8 using the instructions in comment 5. I can confirm that TeliaSonera's new root CA was correctly added and the trust bits were set correctly. Connections to our sites work as expected.
Thanks for testing.
We are targeting Firefox 29 for this change.
https://wiki.mozilla.org/RapidRelease/Calendar
done as part of bug 957300
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.